1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29
|
DHFLAGS=--parallel
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
%:
dh $@ $(DHFLAGS)
override_dh_install:
rm -rfv debian/tmp/usr/lib/*/eom/plugins/*.la
dh_install --fail-missing
override_dh_auto_configure:
NOCONFIGURE=1 ./autogen.sh
dh_auto_configure $(DHFLAGS) -- \
--disable-python \
--with-gtk=3.0
override_dh_installchangelogs:
dh_installchangelogs NEWS
override_dh_strip:
dh_strip --dbgsym-migration='eom-dbg (<< 1.14.1-2~)'
get-orig-source:
uscan --noconf --force-download --rename --download-current-version --destdir=..
|