1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
include /usr/share/dpkg/default.mk
VER_MAJOR := $(shell echo $(DEB_VERSION_UPSTREAM) | sed 's/^\([0-9]\+\)\..*/\1/')
VER_MINOR := $(shell echo $(DEB_VERSION_UPSTREAM) | sed 's/^[0-9]\+\.\([0-9]\+\)\..*/\1/')
VER_BUILD := $(shell echo $(DEB_VERSION_UPSTREAM) | sed 's/^[0-9]\+\.[0-9]\+\.\(.*\)/\1/')
CFLAGS += -I. -g2 -DDEALLOCATE=0 -DVERSION=\"$(DEB_VERSION_UPSTREAM)\" -DVER_MAJOR=$(VER_MAJOR) -DVER_MINOR=$(VER_MINOR) -DVER_BUILD=$(VER_BUILD) -DSTANDALONE=1
LDFLAGS += -L.
%:
dh $@
override_dh_auto_clean:
rm -fr epcr
rm -f *_depend.mk
rm -f libepcr.a *.o
rm -f e-PCR famap fahash re-PCR
override_dh_auto_build:
dh_auto_build -- links depend all OPTIMIZE=6
override_dh_auto_install:
# do nothing
|