File: changelog

package info (click to toggle)
equinox-framework 4.17-3
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 14,492 kB
  • sloc: java: 119,528; ansic: 5,578; xml: 1,710; sh: 215; makefile: 15
file content (131 lines) | stat: -rw-r--r-- 3,913 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
equinox-framework (4.17-3) unstable; urgency=medium

  * Team upload.
  * Source only upload.

 -- Sudip Mukherjee <sudipm.mukherjee@gmail.com>  Sat, 10 Oct 2020 21:50:01 +0100

equinox-framework (4.17-2) unstable; urgency=medium

  * Team upload.

  [ Sudip Mukherjee ]
  * Build libequinox-executable-jni.
    - Launcher was unable to connect to JNIBridge.

  [ Emmanuel Bourg ]
  * Clean the binary files.
  * Support building only the arch specific package.
  * Extract the version of libequinox-executable-jni from feature.xml.
  * Added a dependency on libequinox-executable-jni to libequinox-launcher-java.

 -- Sudip Mukherjee <sudipm.mukherjee@gmail.com>  Wed, 07 Oct 2020 22:23:21 +0100

equinox-framework (4.17-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patches
  * Switch to debhelper level 13

 -- Emmanuel Bourg <ebourg@apache.org>  Sun, 27 Sep 2020 22:43:56 +0200

equinox-framework (4.16-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patches

 -- Emmanuel Bourg <ebourg@apache.org>  Sun, 28 Jun 2020 22:40:56 +0200

equinox-framework (4.15-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Refreshed the patches
  * Standards-Version updated to 4.5.0
  * Switch to debhelper level 12

 -- Emmanuel Bourg <ebourg@apache.org>  Sat, 25 Apr 2020 15:05:14 +0200

equinox-framework (4.13-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patches
  * Standards-Version updated to 4.4.1

 -- Emmanuel Bourg <ebourg@apache.org>  Sat, 28 Dec 2019 18:29:24 +0100

equinox-framework (4.12-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patches

 -- Emmanuel Bourg <ebourg@apache.org>  Wed, 17 Jul 2019 11:25:06 +0200

equinox-framework (4.11-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patches
  * Standards-Version updated to 4.4.0

 -- Emmanuel Bourg <ebourg@apache.org>  Wed, 10 Jul 2019 09:52:52 +0200

equinox-framework (4.10-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patch
  * The license changed to EPL-2.0
  * Standards-Version updated to 4.3.0

 -- Emmanuel Bourg <ebourg@apache.org>  Thu, 27 Dec 2018 23:23:21 +0100

equinox-framework (4.9-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patch
    - Disabled the new OpenJ9 features (not in Debian)

 -- Emmanuel Bourg <ebourg@apache.org>  Mon, 03 Dec 2018 08:50:34 +0100

equinox-framework (4.8-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patch
    - No longer build the removed org.eclipse.osgi.compatibility.plugins bundle
  * Fixed the watch file

 -- Emmanuel Bourg <ebourg@apache.org>  Tue, 27 Nov 2018 11:25:24 +0100

equinox-framework (4.7.3-5) unstable; urgency=medium

  * Fixed the reversed groupId/artifactId in the Maven poms

 -- Emmanuel Bourg <ebourg@apache.org>  Sat, 13 Oct 2018 00:26:19 +0200

equinox-framework (4.7.3-4) unstable; urgency=medium

  * Added the missing dependencies in the Maven poms
  * Added the Class-Path attribute in the manifest of the jar files

 -- Emmanuel Bourg <ebourg@apache.org>  Mon, 01 Oct 2018 13:03:07 +0200

equinox-framework (4.7.3-3) unstable; urgency=medium

  * Mark the libeclipse-osgi-java, libeclipse-osgi-services-java and
    libeclipse-osgi-util-java package as breaking and replacing
    libequinox-osgi-java (<< 3.9.1-2~)

 -- Emmanuel Bourg <ebourg@apache.org>  Thu, 27 Sep 2018 13:30:17 +0200

equinox-framework (4.7.3-2) unstable; urgency=medium

  * Handle the conflict between libeclipse-osgi-java and libequinox-osgi-java
    (Closes: #907863)
  * Standards-Version updated to 4.2.1

 -- Emmanuel Bourg <ebourg@apache.org>  Wed, 05 Sep 2018 15:23:04 +0200

equinox-framework (4.7.3-1) unstable; urgency=medium

  * Initial release (Closes: #903617)

 -- Emmanuel Bourg <ebourg@apache.org>  Thu, 12 Jul 2018 01:16:11 +0200