File: changelog

package info (click to toggle)
fabric 1.14.0-1
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid
  • size: 1,240 kB
  • sloc: python: 7,363; makefile: 10
file content (270 lines) | stat: -rw-r--r-- 8,578 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
fabric (1.14.0-1) unstable; urgency=medium

  * New upstream release.
  * Bump Standards-Version to 4.1.2, no changes.

 -- Andrew Starr-Bochicchio <asb@debian.org>  Mon, 25 Dec 2017 20:55:31 -0500

fabric (1.13.1-3) unstable; urgency=medium

  * Run tests in verbose mode (Closes: #857094).

 -- Andrew Starr-Bochicchio <asb@debian.org>  Tue, 07 Mar 2017 20:10:33 -0500

fabric (1.13.1-2) unstable; urgency=medium

  * debian/rules: Disable test_nested_execution_with_explicit_ports
    when running tests at build time as it hangs indefinitely
    when run on a single core VM (Closes: #850230).

 -- Andrew Starr-Bochicchio <asb@debian.org>  Wed, 18 Jan 2017 22:32:02 -0500

fabric (1.13.1-1) unstable; urgency=medium

  * New upstream release.
  * Drop 0003-allow-paramiko-2.patch, applied upstream.
  * Bump debian/compat to 10.

 -- Andrew Starr-Bochicchio <asb@debian.org>  Sat, 24 Dec 2016 13:35:22 -0500

fabric (1.12.0-1) unstable; urgency=medium

  * New upstream release.
  * 0002-disable-failed-tests-with-fudge10.patch: Disable tests that
    require Fudge < 1.0 so that we can run the rest of the test suite.
  * debian/rules: Re-enable the test suite.
  * debian/control:
   - Build depend on python-fudge and python-nose.
   - Bump Standards-Version to 3.9.8, no changes.
   - Build depend and depend on python-crypto.
   - Drop unneeded depend on python-nose.
  * 0003-allow-paramiko-2.patch: Patch setup.py to allow
    Paramiko 2.

 -- Andrew Starr-Bochicchio <asb@debian.org>  Sat, 12 Nov 2016 12:45:54 -0500

fabric (1.10.2-1) unstable; urgency=medium

  [ Stein Magnus Jodal ]
  * New upstream release.
  * debian/control:
    - Build-Depend on debhelper >= 9.
    - Build-Depend on python-all >= 2.7.
    - Build-Depend on dh-python.
    - Replace debian/pyversions with X-Python-Version declaration.
  * debian/copyrights:
    - Use DEP5 format.
    - Update upstream and package copyrights.
    - Update upstream license from GPLv2 to BSD-2-clause, as upstream changed
      license in 2009.
  * Install docs with dh_sphinxdoc. This fixes embedded-javascript-library
    Lintian warning for Underscore.js.
  * Update debian/watch.
  * Use pybuild as build system.
  * Replace AdSense removal patch with a new cleanly applying patch with the
    same license as the upstream source.

  [ Andrew Starr-Bochicchio ]
  * Add myself as Maintainer (Closes: #797593).
  * Fix typo in debian/watch.
  * debian/fab.1: Update to be more comprehensive based on
    on the upstream usage docs.

 -- Andrew Starr-Bochicchio <asb@debian.org>  Tue, 15 Sep 2015 22:32:39 -0400

fabric (1.10.0-1) unstable; urgency=medium

  * New upstream release. (Closes: #760152)
  * Update versioned depends on python-paramiko to >= 1.10.
    Thanks David Banks for the suggestion. (Closes: #740930)
  * Update Vcs-* fields.
  * Packaging updates to generate the documentation:
    - Add b-d on python-alabaster.
    - Drop patch disable_sphinx_extension.patch.
    - Update debian/rules accordingly.
    - Update no_adsense patch to work with the new doc system.
  * Update to Standards-Version 3.9.6, no changes required.

 -- Ana Beatriz Guerrero Lopez <ana@debian.org>  Sun, 05 Oct 2014 02:35:21 +0200

fabric (1.8.2-1) unstable; urgency=medium

  * New upstream release.
  * New maintainer. (Closes: #738292)
  * Bump debian/compat to 8
  * Update Standards-Version: 3.9.5, no changes required.
  * Change Vcs-Git and Vcs-Git fields to my github copy.
  * Modify debian/copyright to add myself in the packaging copyright.
  * Add patch no_adsense.patch, to remove Google Adsense in the html documentation.
  * Disable sphinx extension "releases", it is not included in Debian. See
    patch disable_sphinx_extension.patch.

 -- Ana Beatriz Guerrero Lopez <ana@debian.org>  Sat, 22 Feb 2014 23:01:27 +0100

fabric (1.7.0-2) unstable; urgency=medium

  * Orphaning package.

 -- Chris Lamb <lamby@debian.org>  Sat, 08 Feb 2014 23:50:33 +0000

fabric (1.7.0-1) unstable; urgency=low

  * New upstream release.
    Thanks to Rodney Lorrimar <rlorrimar@ccg.murdoch.edu.au>.
  * Drop 01-paramiko.diff - equivalent change made upstream.

 -- Chris Lamb <lamby@debian.org>  Tue, 06 Aug 2013 12:06:30 +0100

fabric (1.4.3-1) unstable; urgency=low

  * New upstream release (Closes: #680209)
  * Drop 02-no-upstream-tags-when-building.diff.
  * Bump Standards-Version to 3.9.3.

 -- Chris Lamb <lamby@debian.org>  Mon, 29 Oct 2012 23:59:13 +0000

fabric (1.4.2-1.1) unstable; urgency=low

  * Fix paramiko incompatiblity with python-ssh. Thanks to Emmanuel Bouthenot
    (Closes: #677479)

 -- Chris Lamb <lamby@debian.org>  Fri, 22 Jun 2012 10:23:10 +0100

fabric (1.4.2-1) unstable; urgency=low

  * New upstream release.

 -- Chris Lamb <lamby@debian.org>  Wed, 13 Jun 2012 16:31:01 +0100

fabric (1.3.2-5) unstable; urgency=low

  * Move to dh_python2 from python-support. Patch by/via Micah Gersten
    <micahg@ubuntu.com>. (Closes: #653322)
  * Add missing python-paramiko to Build-Depends. (Closes: #653321)

 -- Chris Lamb <lamby@debian.org>  Tue, 03 Jan 2012 12:43:42 +0000

fabric (1.3.2-4) unstable; urgency=low

  * Call "install" in override_dh_auto_install, not "clean".
    (Closes: #651599)
  * Add missing python-sphinx dependency. (Closes: #651597, #651602)

 -- Chris Lamb <lamby@debian.org>  Wed, 14 Dec 2011 16:41:43 +0000

fabric (1.3.2-3) unstable; urgency=low

  * Ship documentation. (Closes: #649610)

 -- Chris Lamb <lamby@debian.org>  Thu, 08 Dec 2011 14:51:01 +0000

fabric (1.3.2-2) unstable; urgency=low

  * Use paramiko instead of "ssh" library. It is not yet packaged for Debian
    and paramiko appears to work in my quick tests and is better than it just
    failing. (Closes: #649161)
  * Add new python-nose dependency.

 -- Chris Lamb <lamby@debian.org>  Fri, 18 Nov 2011 15:17:45 +0000

fabric (1.3.2-1) unstable; urgency=low

  * New upstream release (Closes: #648483)
  * Update debian/watch.

 -- Chris Lamb <lamby@debian.org>  Wed, 16 Nov 2011 17:32:19 +0000

fabric (1.1.2-1) unstable; urgency=low

  * New upstream release.

 -- Chris Lamb <lamby@debian.org>  Thu, 28 Jul 2011 19:32:36 +0200

fabric (1.0.2-1) unstable; urgency=low

  * New upstream release.
  * Bump Standards-Version to 3.9.2.

 -- Chris Lamb <lamby@debian.org>  Tue, 28 Jun 2011 19:54:22 +0100

fabric (1.0.1-1) unstable; urgency=low

  * New upstream release (Closes: #627123)

 -- Chris Lamb <lamby@debian.org>  Tue, 17 May 2011 21:54:50 +0100

fabric (0.9.3-1) unstable; urgency=low

  * New upstream release (Closes: #612361)
  * Update Vcs-{Git,Browser}.

 -- Chris Lamb <lamby@debian.org>  Sun, 27 Feb 2011 21:27:34 +0000

fabric (0.9.2-1) unstable; urgency=low

  * New upstream release. (Closes: #597973)

 -- Chris Lamb <lamby@debian.org>  Thu, 07 Oct 2010 21:42:30 +0100

fabric (0.9.1-1) unstable; urgency=low

  * New upstream release.
  * Bump Standards-Version to 3.9.1.

 -- Chris Lamb <lamby@debian.org>  Sun, 01 Aug 2010 16:14:40 -0400

fabric (0.9.0-3) unstable; urgency=low

  * Don't try and install changes/ directory; something in sid now means this
    is causing a FTBFS. (Closes: #587138)
  * Switch to dpkg v3 source format.
  * Bump Standards-Version to 3.8.4.

 -- Chris Lamb <lamby@debian.org>  Mon, 28 Jun 2010 10:44:43 +0100

fabric (0.9.0-2) unstable; urgency=low

  * Don't embed python-paramiko. (Closes: #561398)

 -- Chris Lamb <lamby@debian.org>  Tue, 05 Jan 2010 21:47:56 +0000

fabric (0.9.0-1) unstable; urgency=low

  * New upstream release (Closes: #555796)
  * Update debian/watch.
  * debian/control:
    - Add missing binary dependency on python-pkg-resources (Closes: #557144)
    - Update Homepage field.
    - Bump Standards-Version.

 -- Chris Lamb <lamby@debian.org>  Mon, 23 Nov 2009 01:28:29 +0000

fabric (0.1.1-1) unstable; urgency=low

  * New upstream release.
  * Set section to 'net' from 'python'.
  * Bump Standards-Version to 3.8.1

 -- Chris Lamb <lamby@debian.org>  Sat, 09 May 2009 12:59:18 +0100

fabric (0.1.0-1) unstable; urgency=low

  * New upstream release.
  * Correct title of manual page.
  * Correct typo in debian/copyright.
  * Updating location of Git URLs.

 -- Chris Lamb <lamby@debian.org>  Sun, 22 Feb 2009 02:49:44 +0000

fabric (0.0.9-2) unstable; urgency=low

  * Add missing Build-Depends-Indep on python-setuptools. Found by checking
    source-only upload to Ubuntu.

 -- Chris Lamb <lamby@debian.org>  Thu, 08 Jan 2009 23:36:39 +0000

fabric (0.0.9-1) unstable; urgency=low

  * Initial release. (Closes: #504799)

 -- Chris Lamb <lamby@debian.org>  Sat, 08 Nov 2008 03:29:25 +0000