File: README

package info (click to toggle)
farstream-0.2 0.2.8-5
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 7,944 kB
  • sloc: ansic: 43,088; sh: 12,143; perl: 3,071; python: 1,921; makefile: 803; xml: 692
file content (39 lines) | stat: -rw-r--r-- 861 bytes parent folder | download | duplicates (3)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
Farstream
==========

http://www.freedesktop.org/wiki/Software/Farstream

Farstream is a collection of GStreamer modules and libraries for
videoconferencing. The API is described in the documentation in the
docs/ directory.

It is distributed under the terms of the GNU Lesser General Public
License version 2.1 or later (see the COPYING file for details).


Requirements
============

Build time:
 - gstreamer 1.4.0
 - gst-plugins-base 1.4.0
 - glib 2.32
 - libnice 0.1.8
 - gobject-introspection 0.10.1

For UPnP support:
 - GUPnP-IGD

Run time for the RTP plugin:
 All of the build time requirements (except gtk-doc) plus
 - gst-plugins-good 1.4.0
 - gst-plugins-bad 1.4.0

Run time for the MSN plugin:
 - gst-plugins-bad 1.4.0

For the GUI example:
 - Gtk 3.0

The tests require gst-check and GStreamer 1.0.1
Building the documentation requires gtk-doc 1.8