1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68
|
CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
config/config.me: configure
dh_testdir
./configure --debian --without-fastdep
build: build-stamp
build-stamp: config/config.me
dh_testdir
LDFLAGS="$(LDFLAGS)" CFLAGS="$(CFLAGS)" $(MAKE)
cd tests && ./run.sh
./fastdep ./Define.cc ./FileCache.cc > /dev/null
touch build-stamp
clean:
dh_testdir
dh_testroot
rm -f build-stamp
[ ! -f Makefile ] || $(MAKE) clean
rm -f config/a.out
rm -f tests/last/*.out
dh_clean --exclude ./FileCache.cc.orig --exclude ./FileCache.h.orig --exclude ./Include.cc.orig --exclude ./fastdep.cc.orig
install: build
dh_testdir
dh_testroot
dh_prep --exclude ./FileCache.cc.orig --exclude ./FileCache.h.orig --exclude ./Include.cc.orig --exclude ./fastdep.cc.orig
dh_installdirs
dh_install fastdep /usr/bin/
build-arch: build
build-indep: build
binary-indep: install
binary-arch: install
dh_testdir
dh_testroot
dh_installchangelogs CHANGELOG
dh_installdocs
dh_install doc/c*.htm /usr/share/doc/fastdep/manual/
dh_install doc/fastdep.html /usr/share/doc/fastdep/manual/
dh_install doc/fastdep.pdf /usr/share/doc/fastdep/
dh_link /usr/share/doc/fastdep/manual/fastdep.html /usr/share/doc/fastdep/manual/book1.htm
dh_installman doc/fastdep.1
dh_strip
dh_compress
dh_fixperms
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install
|