1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
|
Description: fix implicit return type for main.
Fix the following error cropping up with gcc 14:
.
fastDNAml.c:4751:3: error: return type defaults to ‘int’ [-Wimplicit-int]
4751 | main ()
| ^~~~
Author: Étienne Mollier <emollier@debian.org>
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1074947
Forwarded: no
Last-Update: 2024-07-20
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
@@ -4748,9 +4748,9 @@
/*
#if Sequential
- main ()
+ int main ()
#else
- slave ()
+ int slave ()
#endif
{ /* DNA Maximum Likelihood */
# if Master
|