1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
%:
dh $@ --with python3 --buildsystem=cmake
override_dh_auto_configure: fasttext.1
dh_auto_configure --buildsystem=cmake
dh_auto_configure --buildsystem=pybuild
override_dh_auto_build:
dh_auto_build --buildsystem=cmake
dh_auto_build --buildsystem=pybuild
override_dh_auto_install:
dh_auto_install --buildsystem=cmake
dh_auto_install --buildsystem=pybuild
find $(CURDIR)/debian/tmp -name '*.a' -print0 | xargs -0 rm -f {}\;
override_dh_auto_clean:
dh_auto_clean --buildsystem=cmake
-rm -rf fasttext.1
-rm -rf .pybuild
-rm -rf python/fasttext_module/fasttext.egg-info
-rm -rf build
-rm -rf tmp
DB2MAN = /usr/share/sgml/docbook/stylesheet/xsl/docbook-xsl/manpages/docbook.xsl
XP = xsltproc -''-nonet -''-param man.charmap.use.subset "0"
fasttext.1: debian/fasttext.xml
$(XP) $(DB2MAN) $<
|