1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113
|
DH_VERBOSE = 1
export VERBOSE = 1
DEB_SRCDIR=build
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/default.mk
CXXFLAGS+=$(CPPFLAGS)
CFLAGS+=$(CPPFLAGS)
export http_proxy = http://127.0.0.1:9
export https_proxy = https://127.0.0.1:9
%:
dh $@
override_dh_auto_build:
dh_auto_build -- \
world PREFIX=/usr
override_dh_installchangelogs:
dh_installchangelogs WHATSNEW.md
override_dh_installman: manpages
dh_installman
override_dh_auto_install:
dh_auto_install -- PREFIX=/usr
mkdir -p $(CURDIR)/debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)
mv $(CURDIR)/debian/tmp/usr/lib/lib*.* $(CURDIR)/debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)
sed -e 's|^\( *\. \)faust|\1/usr/share/faust/utils/faust|' \
-e 's|^\( *\. \)usage.sh|\1/usr/share/faust/utils/usage.sh|' \
-i $(CURDIR)/debian/*/usr/bin/faust2*
override_dh_auto_install-indep:
rm -rf $(CURDIR)/debian/tmp/usr/share/faust/iOS/osclib/
find $(CURDIR)/debian/tmp/usr/share/faust -name "*.cpp" \
-exec chmod a-x {} +
find $(CURDIR)/debian/tmp/usr/share/faust -name "*.jucer" \
-exec chmod a-x {} +
override_dh_gencontrol:
dh_gencontrol -- \
-V"faust-dev:Depends=g++,make,libc6-dev|libc-dev, faust (>= ${source:Version}),faust (<< ${source:Upstream-Version}+1~),"
override_dh_strip:
dh_strip -Xlibsndfile.so
override_dh_shlibdeps:
dh_shlibdeps -Xlibsndfile.so
override_dh_compress:
dh_compress -Xfaust-quick-reference.pdf
override_dh_clean: manpageclean
dh_clean
-rm -rf build/bin/ build/faustdir/ build/lib/
-rm -f tools/sound2faust/sound2faust tools/sound2faust/sound2file
override_dh_auto_clean:
DEB_COPYRIGHT_CHECK_IGNORE_REGEX = \
(\.git/|\.pc/|debian/|.*\.(png|pdf|doctree|jar|xcuserstate|swc|ots))
DEB_COMPRESS_EXCLUDE_ALL=.dsp .lib Makefile
MANPAGEDIR=debian/man
.PHONY: manpages manpageclean
manpages:
mkdir -p $(MANPAGEDIR)
help2man -N -n "Compile faust DSP code into SuperCollider module" \
tools/faust2sc-1.0.0/faust2sc > $(MANPAGEDIR)/faust2sc.1
debian/faust2man $(MANPAGEDIR) debian/faust2api.1
manpageclean:
-rm -rf $(MANPAGEDIR)
.PHONY: missing-sources
missing-sources: debian/missing-sources/jquery-1.7.1.js
debian/missing-sources/jquery-1.7.1.js:
wget -O $@ https://raw.githubusercontent.com/jquery/jquery/1.7.1/jquery.js
licensecheck:
licensecheck -i "^$(DEB_COPYRIGHT_CHECK_IGNORE_REGEX)$$" --deb-machine -r * \
> debian/copyright_newhints
cmp debian/copyright_hints debian/copyright_newhints \
&& rm debian/copyright_newhints
|