File: changelog

package info (click to toggle)
fcgiwrap 1.1.0-12
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 280 kB
  • sloc: ansic: 703; sh: 198; makefile: 35
file content (211 lines) | stat: -rw-r--r-- 7,909 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
fcgiwrap (1.1.0-12) unstable; urgency=medium

  * Add fcgiwrap to test dependencies

 -- Peter Colberg <peter@colberg.org>  Sun, 09 Dec 2018 10:58:10 -0500

fcgiwrap (1.1.0-11) unstable; urgency=medium

  * Set Maintainer address to team+fcgiwrap@tracker.debian.org
  * Point Vcs-* urls to salsa.debian.org
  * Bump debhelper compat level to 11
  * Set Priority to optional as per policy 4.0.1
  * Update Standards-Version to 4.2.1
  * Propagate CC from configure to make to fix cross-building.
    Thanks to Helmut Grohne (Closes: #900796)
  * Add environment variable NO_BUFFERING to disable output buffering.
    Thanks to Peter Michael Green (Closes: #863478)
  * Add git-http-backend autopkgtest

 -- Peter Colberg <peter@colberg.org>  Sat, 08 Dec 2018 15:03:50 -0500

fcgiwrap (1.1.0-10) unstable; urgency=medium

  * Fix FTBFS with GCC 7 (Closes: #853397)
  * Bump debhelper compat level to 10
  * Drop Build-Depends on dh-autoreconf and dh-systemd
  * Use https for copyright-format URL
  * Update Standards-Version to 4.0.0
  * Bump year in debian/copyright

 -- Peter Colberg <peter@colberg.org>  Sat, 05 Aug 2017 12:16:12 -0400

fcgiwrap (1.1.0-9) unstable; urgency=medium

  * Depend on lsb-base (>= 3.0-6) for /lib/lsb/init-functions

 -- Peter Colberg <peter@colberg.org>  Sat, 22 Oct 2016 07:54:39 -0400

fcgiwrap (1.1.0-8) unstable; urgency=medium

  * Remove Sergio Talens-Oliag from Uploaders with many thanks for his work
    (Closes: #831757)

 -- Peter Colberg <peter@colberg.org>  Sat, 24 Sep 2016 01:00:39 -0400

fcgiwrap (1.1.0-7) unstable; urgency=medium

  * Override dh_auto_configure instead of manually invoking configure
  * Build with hardening flags (Closes: #828804)
  * Depend on spawn-fcgi only when systemd is not installed (Closes: #828794)
  * Run wrap-and-sort
  * Add debian/gbp.conf for pristine-tar
  * Bump Standards-Version to 3.9.8
  * Update Vcs fields to git repository
  * Drop unused dependency on automake
  * Relicense debian/* to Expat to match upstream license (Closes: #830742)
  * Set myself as Maintainer (Closes: #829654)

 -- Peter Colberg <peter@colberg.org>  Thu, 28 Jul 2016 00:17:47 -0400

fcgiwrap (1.1.0-6) unstable; urgency=medium

  * Add patch to build against libsystemd (closes: #779755; thanks, mbiebl!).
  * Bump Standards-Version to 3.9.6.
  * Use github as Homepage, the real one has been down for ages.
  * Add patch from Dmitry Smirnov to make the systemd unit read DAEMON_OPTS
    from /etc/default/fcgiwrap (closes: #792705).

 -- Jordi Mallach <jordi@debian.org>  Sat, 25 Jul 2015 18:52:09 +0200

fcgiwrap (1.1.0-5) unstable; urgency=medium

  * Add a prerm script that forcibly stops fcgiwrap.socket, to avoid
    respawns via socket activation.

 -- Jordi Mallach <jordi@debian.org>  Thu, 02 Apr 2015 19:00:46 +0200

fcgiwrap (1.1.0-4) unstable; urgency=medium

  * Ensure the socket unit is started upon installation by making
    fcgiwrap.service Require fcgiwrap.socket (closes: #781524). Thanks,
    Michael Biebl!

 -- Jordi Mallach <jordi@debian.org>  Wed, 01 Apr 2015 09:56:53 +0200

fcgiwrap (1.1.0-3) unstable; urgency=medium

  * Ensure fcgiwrap.socket is enabled via dh-systemd (closes: #742439).

 -- Jordi Mallach <jordi@debian.org>  Sat, 10 May 2014 02:02:39 +0200

fcgiwrap (1.1.0-2) unstable; urgency=medium

  * Enable systemd support only on Linux architectures.

 -- Jordi Mallach <jordi@debian.org>  Thu, 02 Jan 2014 12:23:16 +0100

fcgiwrap (1.1.0-1) unstable; urgency=low

  [ Jordi Mallach ]
  * New upstream release (closes: #721518).
  * Remove all patches, all were applied upstream.
  * Add pkg-config to Build-Depends, as per configure.ac.
  * Minor tabs-vs-spaces cosmetic fix in init.
  * Pull post-1.1.0 patches from Git:
    - debian/patches/0002-Add-p-path-option-to-restrict-scripts.patch:
      restricts fcgiwrap to a literal path match.
  * Pass --with-systemdsystemunitdir=/lib/systemd/system.
  * Build-Depend on libsystemd-daemon-dev and pass --with-systemd to
    enable systemd socket activation.
  * Update to debhelper compat v9.
  * Use canonical Vcs URLs.
  * Bump Standards-Version to 3.9.5 (no changes needed).

  [ Sergio Talens-Oliag ]
  * Update watch file as suggested by Haha Warosu (closes: #720912).
  * Added -f option to fcgiwrap to redirect stderr (closes: #633116).
  * Modified init file to remove the use of DAEMON_USER and DAEMON_GID, as
    spawn-fcgi already does the check and fails if the user does not exist
    and also changed the PID file extension (closes: #697856).
  * Use env -i when calling spawn-fcgi to have a clean environment when
    executing the scripts (closes: #621754), but enabling the option of
    exporting some variables if desired (ENV_VARS).
  * Add fix_systemd.patch: change user/group and socket name definitions
    in service file to match the Debian-suitable sysvinit values.
  * Cleanup autotools files on clean.

 -- Jordi Mallach <jordi@debian.org>  Thu, 19 Dec 2013 19:27:31 +0100

fcgiwrap (1.0.3-3) unstable; urgency=low

  * Remove Replaces on old package name that never hit the official
    archive.
  * Actually use $DAEMON_OPTS when spawning the server (closes: #616551).
  * Add support for FCGI_SOCKET_USER & FCGI_SOCKET_GROUP, as suggested by
    Maik Zumstrull (closes: #616552).
  * Add an example default file.

 -- Jordi Mallach <jordi@debian.org>  Fri, 01 Apr 2011 22:08:52 +0200

fcgiwrap (1.0.3-2.1) unstable; urgency=low

  [ Jordi Mallach ]
  * Unquote $pid and $DAEMON on stop_daemon() so it actually stops
    (closes: #602199).
  * Reduce the wait when just stopping (closes: #602200).
  * Change priority to extra.
  * Add ldflags.patch to add support for LDFLAGS in Makefile.in
    (stolen from Git 58ec209478f50b2048cf).

  [ Philipp Kern ]
  * Current state taken from the VCS and uploaded as a LowThresholdNmu.

 -- Philipp Kern <pkern@debian.org>  Tue, 29 Mar 2011 13:19:19 +0200

fcgiwrap (1.0.3-1) unstable; urgency=low

  * New upstream release.
  * Use my debian.org address all over the packaging files.
  * Drop our manpage, which was accepted upstream.
  * Remove obsolete comment about lack of formal fcgiwrap releases and
    versioning of git snapshots.
  * Add a call to `autoreconf -i` on build.
  * Add automake to Build-Depends, and wrap them.
  * Bump Standards-Version to 3.9.1 (no changes needed).
  * Add manpage_minus_escaping.patch to fix a pair of unescaped minus
    signs in the manpage.

 -- Jordi Mallach <jordi@debian.org>  Wed, 01 Sep 2010 20:47:37 +0200

fcgiwrap (1.0-1) unstable; urgency=low

  * New upstream release.
  * Rename source and binary, as agreed with upstream.
  * Minor cosmetic fix to the init script start message.
  * Bump Standards-Version to 3.8.4 (no changes needed).
  * Move to dh7.
  * Switch to Source format 3.0 (quilt).
  * Build-Depend on autoconf.
  * Make the init script depend on $remote_fs (lintian).
  * Move to collab-maint SVN; add appropriate Vcs headers.
  * Initial upload to Debian (closes: #544702).

 -- Jordi Mallach <jordi@debian.org>  Tue, 25 May 2010 21:27:00 +0200

gnosek-fcgiwrap (0.0.20090717.28ac6f9-1) unstable; urgency=low

  * New upstream git pull.
    + explicitly licenced under the MIT licence.
  * Add new licensing information in debian/copyright.
  * Add a note about the Debian versioning scheme to README.Debian.

 -- Jordi Mallach <jordi@debian.org>  Wed, 02 Sep 2009 08:38:09 +0200

gnosek-fcgiwrap (0.0.20090304.cdd6b84-3) unstable; urgency=low

  * Renamed monit example to monitrc. 

 -- Sergio Talens-Oliag <sto@debian.org>  Thu, 02 Apr 2009 15:42:34 +0200

gnosek-fcgiwrap (0.0.20090304.cdd6b84-2) unstable; urgency=low

  * Added monit.conf example.

 -- Sergio Talens-Oliag <sto@debian.org>  Thu, 02 Apr 2009 15:38:10 +0200

gnosek-fcgiwrap (0.0.20090304.cdd6b84-1) unstable; urgency=low

  * Initial release (April Fools).

 -- Sergio Talens-Oliag <sto@debian.org>  Wed, 01 Apr 2009 11:57:46 +0200