1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37
|
export DEB_BUILD_MAINT_OPTIONS=hardening=+all reproducible=+all future=+lfs
include /usr/share/dpkg/architecture.mk
supported_archs = amd64
ignore_tests = $(if $(filter-out $(supported_archs),$(DEB_HOST_ARCH)),-,)
ifeq ($(DEB_HOST_ARCH),$(filter $(DEB_HOST_ARCH),mipsel))
export DEB_BUILD_MAINT_OPTIONS=parallel=1 hardening=+all reproducible=+all future=+lfs
CMAKE_FLAGS = -DCMAKE_EXE_LINKER_FLAGS="-fuse-ld=gold -Wl,--no-map-whole-files -Wl,--no-keep-memory -Wl,--no-keep-files-mapped" \
-DCMAKE_SHARED_LINKER_FLAGS="-fuse-ld=gold -Wl,--no-map-whole-files -Wl,--no-keep-memory -Wl,--no-keep-files-mapped" \
-DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_FLAGS=-Wa,--reduce-memory-overheads
no_dbssym = --no-automatic-dbgsym
endif
%:
dh $@
override_dh_auto_configure:
dh_auto_configure -- \
-DBUILD_TESTING=ON \
-DFCL_NO_DEFAULT_RPATH=OFF \
-DFCL_USE_X64_SSE=OFF \
$(CMAKE_FLAGS)
override_dh_auto_test:
$(ignore_tests)dh_auto_test
override_dh_strip:
dh_strip $(no_dbssym)
|