1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38
|
export DH_VERBOSE=1
%:
dh $@ --with python2,python3
override_dh_auto_build:
dh_auto_build
python3 setup.py build
override_dh_auto_install:
dh_auto_install
python3 setup.py install --root=$(CURDIR)/debian/tmp --install-layout=deb
cp feedparser/sgmllib3.py $(CURDIR)/debian/tmp/usr/lib/python3/dist-packages/feedparser_sgmllib3.py
override_dh_auto_clean:
dh_auto_clean
rm -rf build .*egg-info
override_dh_auto_test:
cp $(CURDIR)/debian/upstream/*.z feedparser/tests/compression
cp $(CURDIR)/debian/upstream/*.gz feedparser/tests/compression
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
cd feedparser && python ./feedparsertest.py
else
@echo "nocheck set, not running tests"
endif
override_dh_installdocs:
dh_installdocs -Xtests
override_dh_installchangelogs:
dh_installchangelogs NEWS
|