1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32
|
export DH_VERBOSE=1
include /usr/share/dpkg/pkg-info.mk
export PYBUILD_NAME=feedparser
export PYBUILD_AFTER_INSTALL=chmod a-x {destdir}/usr/lib/{interpreter}/dist-packages/feedparser-$(DEB_VERSION_UPSTREAM).egg-info/*
%:
dh $@ --with python2,python3 --buildsystem pybuild
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
cd feedparser && python ./feedparsertest.py
else
@echo "nocheck set, not running tests"
endif
override_dh_installdocs:
dh_installdocs -Xtests
override_dh_installchangelogs:
dh_installchangelogs NEWS
override_dh_fixperms:
dh_fixperms
chmod a-x debian/python3-feedparser/usr/lib/python*/dist-packages/feedparser_debian/*.py
|