1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71
|
Author: Alastair McKinstry <mckinstry@debian.org>
Description: Debian-specific changes
Exclude xgks/ directory as Debian links against its own copy.
Last-Updated: 2014-09-10
Forwarded: not-needed
@@ -20,8 +20,6 @@ all : optimized
optimized :
mkdir -p lib
$(COPY_DYLIBS)
- $(MAKE) xgks/Makefile
- $(MAKE) -C xgks
$(MAKE) -C fer
cp -f fer/ferret_c bin/ferret
$(MAKE) "FER_DIR = $(DIR_PREFIX)" -C external_functions all
@@ -33,8 +31,6 @@ optimized :
debug :
mkdir -p lib
$(COPY_DYLIBS)
- $(MAKE) xgks/Makefile
- $(MAKE) -C xgks
$(MAKE) -C fer debug
cp -f fer/ferret_c bin/ferret
$(MAKE) "FER_DIR = $(DIR_PREFIX)" -C external_functions debug
@@ -50,8 +46,6 @@ debug :
memorydebug :
mkdir -p lib
$(COPY_DYLIBS)
- $(MAKE) xgks/Makefile
- $(MAKE) -C xgks
$(MAKE) -C fer memorydebug
cp -f fer/ferret_c bin/ferret
$(MAKE) "FER_DIR = $(DIR_PREFIX)" -C external_functions debug
@@ -60,10 +54,6 @@ memorydebug :
$(MAKE) -C bin/build_fonts/unix
-## Configure xgks to create the Makefile if it does not exist
-xgks/Makefile :
- ( cd xgks; export BUILDTYPE=$(BUILDTYPE); ./configure )
-
## Clean all the directories
.PHONY : clean
@@ -76,7 +66,6 @@ clean :
$(MAKE) -C external_functions clean
$(MAKE) -C fer clean
rm -f -R lib dylibs
- $(MAKE) xgksclean
## Thoroughly clean the xgks directory
@@ -37,8 +37,8 @@ include ../ef_utility/platform_specific.
#
#all: chdir.so neutral.so fill_xy.so pco2.so
-#all: chdir.so neutral.so fill_xy.so
-all:
+all: chdir.so neutral.so fill_xy.so
+#ll:
debug:
$(MAKE) "FFLAGS = $(FFLAGS) $(FFLAGS_DEBUG)" "CFLAGS = $(CFLAGS) $(CFLAGS_DEBUG)" all
|