1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,-z,defs
%:
dh $@
override_dh_auto_configure:
dh_auto_configure -- -Duse_native_appchooser=false
override_dh_makeshlibs:
dh_makeshlibs --no-act
override_dh_gencontrol:
ifeq ($(shell dpkg-vendor --query vendor),Ubuntu)
dh_gencontrol -- \
-Vzip:Depends='unzip, zip' \
-Vzip:Suggests='7zip'
else
dh_gencontrol -- \
-Vzip:Depends='7zip' \
-Vzip:Suggests='unzip, zip'
endif
override_dh_gnome_clean:
dh_gnome_clean --no-control
|