1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
|
include /usr/share/dpkg/pkg-info.mk
BUILD_DATE = $(shell LC_ALL=C date -u "+%d %B %Y" -d "@$(SOURCE_DATE_EPOCH)")
SPHINXOPTS := -E -N -D html_last_updated_fmt="$(BUILD_DATE)"
export PYBUILD_NAME=flaskext.wtf
%:
dh $@ --buildsystem=pybuild
override_dh_sphinxdoc:
ifeq (,$(findstring nodoc, $(DEB_BUILD_OPTIONS)))
cd docs && rm -f license.rst
PYTHONPATH=`dirname $$(find .pybuild/ -type d -name "flask_wtf*dist-info" | head -n1)` \
python3 -m sphinx -b html $(SPHINXOPTS) docs/ $(CURDIR)/debian/python-flaskext.wtf-doc/usr/share/doc/python-flaskext.wtf-doc/html
dh_sphinxdoc
endif
|