1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87
|
Source: flask
Section: python
Priority: optional
Maintainer: Piotr Ożarowski <piotr@debian.org>
Uploaders: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>,
Ondřej Nový <onovy@debian.org>
Build-Depends: debhelper (>= 11), dh-python (>= 2.20160609~),
python-all, python3-all,
python-setuptools, python3-setuptools,
# for docs:
python3-sphinx, python3-pallets-sphinx-themes,
# for tests:
python-pytest (>= 3), python3-pytest (>= 3),
python-werkzeug (>= 0.14), python-jinja2 (>= 2.10), python-itsdangerous (>= 0.24), python-blinker, python-click (>= 5.1),
python3-werkzeug (>= 0.14), python3-jinja2 (>= 2.10), python3-itsdangerous (>= 0.24), python3-blinker, python3-click (>= 5.1),
Standards-Version: 4.2.1
Vcs-Git: https://salsa.debian.org/python-team/modules/flask.git
Vcs-Browser: https://salsa.debian.org/python-team/modules/flask
Homepage: http://flask.pocoo.org/
Testsuite: autopkgtest-pkg-python
Package: python-flask
Architecture: all
Depends:
python-werkzeug (>= 0.14), python-jinja2 (>= 2.10), python-itsdangerous (>= 0.24), python-click (>= 5.1),
${python:Depends}, ${misc:Depends}
Recommends: python-pkg-resources,
python-blinker
Suggests: python-flask-doc
Description: micro web framework based on Werkzeug and Jinja2 - Python 2.7
Flask is a micro web framework for Python based on Werkzeug, Jinja 2 and good
intentions. A minimal Flask application looks like that:
.
from flask import Flask
app = Flask(__name__)
.
@app.route("/")
def hello():
return "Hello World!"
.
if __name__ == '__main__':
app.run()
.
This package contains the Python 2.7 module.
Package: python3-flask
Architecture: all
Depends: ${python3:Depends}, ${misc:Depends}
Recommends: python3-pkg-resources,
python3-blinker
Suggests: python-flask-doc
Description: micro web framework based on Werkzeug and Jinja2 - Python 3.x
Flask is a micro web framework for Python based on Werkzeug, Jinja 2 and good
intentions. A minimal Flask application looks like that:
.
from flask import Flask
app = Flask(__name__)
.
@app.route("/")
def hello():
return "Hello World!"
.
if __name__ == '__main__':
app.run()
.
This package contains the Python 3.x module.
Package: python-flask-doc
Section: doc
Architecture: all
Depends: ${misc:Depends}, ${sphinxdoc:Depends}
Recommends: python-flask
Description: micro web framework based on Werkzeug and Jinja2 - documentation
Flask is a micro web framework for Python based on Werkzeug, Jinja 2 and good
intentions. A minimal Flask application looks like that:
.
from flask import Flask
app = Flask(__name__)
.
@app.route("/")
def hello():
return "Hello World!"
.
if __name__ == '__main__':
app.run()
.
This package contains the documentation for Flask.
|