1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77
|
DEB_PYTHON3_MODULE_PACKAGES = flowblade
-include /usr/share/cdbs/1/rules/upstream-tarball.mk
include /usr/share/cdbs/1/rules/utils.mk
include /usr/share/cdbs/1/class/python-distutils.mk
include /usr/share/cdbs/1/rules/debhelper.mk
pkg = $(DEB_SOURCE_PACKAGE)
DEB_UPSTREAM_URL = https://github.com/jliljebl/flowblade/archive
DEB_UPSTREAM_TARBALL_BASENAME = v$(DEB_UPSTREAM_TARBALL_VERSION)
CDBS_BUILD_DEPENDS_class_python-distutils_python =
python-deps = cairo numpy dbus pil gi gi-cairo
gir-deps = glib-2.0 gtk-3.0 pango-1.0 gdkpixbuf-2.0
deps = $(patsubst %,$(comma) python3-%,$(python-deps))
deps +=, $(patsubst %,$(comma) gir1.2-%,$(gir-deps))
deps +=, python3-mlt
deps +=, librsvg2-common, frei0r-plugins, swh-plugins, gmic
CDBS_DEPENDS_$(pkg) = $(deps)
DEB_SRCDIR = flowblade-trunk
src = $(patsubst ./,,$(addsuffix /,$(DEB_SRCDIR)))
DEB_COPYRIGHT_EXTRACT_EXTS = png
DEB_COPYRIGHT_CHECK_IGNORE_EXTS = mo pgm
DEB_INSTALL_DOCS_ALL += README.md $(src)docs/FAQ.md $(src)docs/GDB.md $(src)docs/ROADMAP.md $(src)docs/KNOWN_ISSUES.md
DEB_INSTALL_CHANGELOGS_ALL = $(src)docs/RELEASE_NOTES.md
DEB_PYTHON_INSTALL_ARGS_$(pkg) += --install-lib=/usr/share/flowblade
install/flowblade::
cp $(src)installdata/flowblade debian/flowblade.mime
clean::
rm -f $(patsubst %,debian/flowblade.%,mime sharedmimeinfo desktop)
binary-post-install/$(pkg)::
find $(cdbs_curdestdir) -name '*~' -delete
binary-fixup/$(pkg)::
chmod +x $(cdbs_curdestdir)usr/share/flowblade/Flowblade/launch/*
DEB_CLEAN_EXCLUDE = \
$(src)Flowblade/locale/cs/LC_MESSAGES/Flowblade.po~ \
$(src)Flowblade/locale/de/LC_MESSAGES/Flowblade.po~ \
$(src)Flowblade/locale/es/LC_MESSAGES/Flowblade.po~ \
$(src)Flowblade/locale/fi/LC_MESSAGES/Flowblade.po~ \
$(src)Flowblade/locale/fr/LC_MESSAGES/Flowblade.po~ \
$(src)Flowblade/locale/it/LC_MESSAGES/Flowblade.po~
|