1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37
|
ifneq ($(filter nodoc,$(DEB_BUILD_PROFILES)),)
BUILD_DOC := --disable-docs
else
BUILD_DOC := --enable-docs
endif
%:
dh $@
override_dh_auto_configure:
dh_auto_configure -- --enable-static $(BUILD_DOC) --with-add-fonts=/usr/local/share/fonts
override_dh_makeshlibs:
dh_makeshlibs -plibfontconfig1 -V"libfontconfig1 (>= 2.13)" --add-udeb="fontconfig-udeb" -- -c4
override_dh_strip:
dh_strip --dbgsym-migration='libfontconfig1-dbg (<< 2.12.1-0.1~)'
override_dh_clean:
dh_clean
chmod +w debian/po/*.po
debconf-updatepo
execute_after_dh_install-arch:
cd debian/fontconfig-config/usr/share/fontconfig/conf.avail && \
mv 70-yes-bitmaps.conf 70-force-bitmaps.conf
cp debian/70-yes-bitmaps.conf debian/fontconfig-config/usr/share/fontconfig/conf.avail/
rm debian/fontconfig-config/etc/fonts/conf.d/10-hinting-slight.conf \
debian/fontconfig-config/etc/fonts/conf.d/10-sub-pixel-rgb.conf
override_dh_auto_test:
env --unset=SOURCE_DATE_EPOCH dh_auto_test
|