1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
|
export LC_ALL=C.UTF-8
binaries := $(shell dh_listpackages)
%:
dh $@ --with sphinxdoc --buildsystem=pybuild
export PYBUILD_TEST_ARGS = -k "not afmLib and not tfmLib"
override_dh_auto_build:
python3 MetaTools/buildUCD.py --ucd-path=/usr/share/unicode
PYTHONPATH="./Lib" python3 MetaTools/buildTableList.py
dh_auto_build
ifneq ($(filter python-fonttools-doc,$(binaries)),)
override_dh_sphinxdoc:
sphinx-build $(CURDIR)/Doc/source $(CURDIR)/debian/python-fonttools-doc/usr/share/doc/fonttools/html/
dh_sphinxdoc
endif
|