File: changelog

package info (click to toggle)
fountain-mode 2.8.5-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 316 kB
  • sloc: lisp: 4,119; makefile: 2
file content (114 lines) | stat: -rw-r--r-- 4,147 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
fountain-mode (2.8.5-1) unstable; urgency=medium

  * New upstream release.
  * Harmonise copyright file with upstream updates.
  * Update my copyright years.
  * Add README.Debian with PDF export HOWTO.  Upstream is deprecating this
    functionality in the next release, but if 2.8.5 ends up in the next
    Ubuntu LTS release then users of all the derivatives should be
    provided with documentation.  When upstream cuts out the code for this
    functionality we will need to use something like Oliver Taylor's
    Textplay Ruby script.  At the moment Textplay is missing support for
    title pages, scene numbers, and empty lines in dialogue blocks, so if
    anyone reading this also enjoys working in Ruby, please take a look at
    that project and lend a helping hand.

 -- Nicholas D Steeves <nsteeves@gmail.com>  Sun, 19 Jan 2020 18:44:35 -0500

fountain-mode (2.8.1-1) unstable; urgency=medium

  * New upstream release.

 -- Nicholas D Steeves <nsteeves@gmail.com>  Tue, 12 Nov 2019 18:48:34 -0500

fountain-mode (2.8.0-1) unstable; urgency=medium

  * New upstream release.
  * Drop texlive-generic-recommended as an alternative Recommends for
    texlive-plain-generic; it's going away for bullseye. (Closes: #940899)
  * Update homepage.  This new one is really nice, by the way.

 -- Nicholas D Steeves <nsteeves@gmail.com>  Sat, 12 Oct 2019 17:45:23 -0400

fountain-mode (2.7.3-1) unstable; urgency=medium

  * New upstream release.

 -- Nicholas D Steeves <nsteeves@gmail.com>  Sun, 11 Aug 2019 20:55:37 -0400

fountain-mode (2.7.2-1) unstable; urgency=medium

  * New upstream release.
  * Switch to debhelper-compat 12.
  * Fix typo in this changelog.
  * Drop emacs25 from Enhances.
  * Reflect upstream copyright change to FSF and updated date range.
  * Add upstream contact to copyright file.
  * Update my copyright date range.
  * Declare Standards-Version: 4.4.0. (No changes required)

 -- Nicholas D Steeves <nsteeves@gmail.com>  Fri, 02 Aug 2019 17:44:06 -0400

fountain-mode (2.6.1-1) unstable; urgency=medium

  * New upstream release.
  * Add lintian override for wrong-section-according-to-package-name,
    because "text" is the most appropriate section for screenplay
    writing software.
  * Declare Standards-Version: 4.2.1. (No additional changes needed)

 -- Nicholas D Steeves <nsteeves@gmail.com>  Sun, 21 Oct 2018 15:29:43 -0400

fountain-mode (2.6.0-1) unstable; urgency=medium

  * New upstream release.
  * Restructure the long description and unify style for clarity.
  * Update copyright years.
  * Declare Standards-Version: 4.2.0. (No additional changes needed)

 -- Nicholas D Steeves <nsteeves@gmail.com>  Wed, 08 Aug 2018 22:15:56 -0400

fountain-mode (2.5.3-2) unstable; urgency=medium

  * Change section to text, which is more accurate and discoverable.
  * Declare Standards-Version: 4.1.4. (No additional changes needed)
  * Update Maintainer team name and email address.
  * Add elpa-olivetti and elpa-imenu-list to Recommends. (Closes: #880623)

 -- Nicholas D Steeves <nsteeves@gmail.com>  Tue, 08 May 2018 14:12:33 -0400

fountain-mode (2.5.3-1) unstable; urgency=medium

  * New upstream release.

 -- Nicholas D Steeves <nsteeves@gmail.com>  Wed, 21 Mar 2018 13:06:52 -0400

fountain-mode (2.5.0-1) unstable; urgency=medium

  * New upstream release.
  * Switch Vcs from alioth to salsa.
  * Relax debhelper dependency to 11~ to allow backporting.

 -- Nicholas D Steeves <nsteeves@gmail.com>  Mon, 26 Feb 2018 17:07:39 -0500

fountain-mode (2.4.1-1) unstable; urgency=medium

  * New upstream release.
  * Declare compat level 11.
  * Switch to debhelper 11.
  * Merge upstream changes to long description.
  * Declare Standards-Version: 4.1.3. (No additional changes needed)

 -- Nicholas D Steeves <nsteeves@gmail.com>  Sun, 07 Jan 2018 23:29:00 -0500

fountain-mode (2.3.1-1) unstable; urgency=medium

  * New upstream release.

 -- Nicholas D Steeves <nsteeves@gmail.com>  Mon, 27 Nov 2017 11:16:09 -0500

fountain-mode (2.3.0-1) unstable; urgency=medium

  * Initial release. (Closes: #850337)

 -- Nicholas D Steeves <nsteeves@gmail.com>  Thu, 05 Oct 2017 19:28:02 -0400