1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
|
Use 'DESTDIR' for 'prefix'
* The Makefile uses the variable 'prefix' for what is normally 'DESTDIR'.
Simplest workaround: set prefix from DESTDIR.
* Furthermore, the default value of 'prefix' was '/'. This causes a prefix
of '//' in some cases which may be a problem in e.g. cygwin. No point
keeping it.
--- a/Makefile
+++ b/Makefile
@@ -3,7 +3,7 @@
# Builds "fxload" binaries, distribution tarball, and RPMs.
#
-prefix = /
+prefix = $(DESTDIR)
exec_prefix = ${prefix}
sbindir = ${exec_prefix}/sbin
mandir = ${prefix}/usr/share/man
|