1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
|
include /usr/share/dpkg/pkg-info.mk
export DH_GOLANG_INSTALL_EXTRA := tests/
override_dh_auto_install:
dh_auto_install -- --no-source
override_dh_auto_build:
dh_auto_build
@echo DEB_VERSION_UPSTREAM $(DEB_VERSION_UPSTREAM)
sed -e "s/__VERSION__/$(DEB_VERSION_UPSTREAM)/g" < debian/g10k.1.md.in > debian/g10k.1.md
pandoc debian/g10k.1.md -s -f markdown -t man -o debian/g10k.1
override_dh_auto_install:
dh_auto_install -- --no-source
override_dh_auto_test:
echo "most tests use the network, skipping test suite"
%:
dh $@ --buildsystem=golang --with=golang
|