1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
|
Description: upstream: fix: desauto: wild char array
Initialize a wild char array in src/leon/src/desauto.c
that caused issue at test time.
Origin: vendor, Ubuntu
Forwarded: not-needed, https://github.com/gap-packages/guava/issues/98
Author: Simon Chopin <simon.chopin@canonical.com>
Last-Update: 2024-10-04
@@ -202,7 +202,7 @@
char tempArg[8];
enum { DESIGN_AUTO, DESIGN_ISO, MATRIX_AUTO, MATRIX_ISO, CODE_AUTO,
CODE_ISO} computationType = DESIGN_AUTO;
- char comment[1024];
+ char comment[1024] = "";
/* Check whether the first parameters are iso, code, or matrix.
Set the computation type. */
|