File: changelog

package info (click to toggle)
gap 4r7p5-2
  • links: PTS
  • area: main
  • in suites: jessie, jessie-kfreebsd
  • size: 29,272 kB
  • ctags: 7,129
  • sloc: ansic: 107,802; xml: 46,868; sh: 3,548; perl: 2,329; makefile: 740; python: 94; asm: 62; awk: 6
file content (295 lines) | stat: -rw-r--r-- 10,982 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
gap (4r7p5-2) unstable; urgency=low

  * gap-core.triggers: use interest-noawait. Thanks Guillem Jover.
    Closes: #772869

 -- Bill Allombert <ballombe@debian.org>  Sun, 14 Dec 2014 20:35:04 +0100

gap (4r7p5-1) unstable; urgency=low

  * New upstream release
   + Note that gap-gdat 4r7p5 is identical to gap-gdat 4r7p3.
   + Patches applied upstream:
    - gac-itanium: removed
    - gap-fix-alignment: removed
  * New patches added:
   - fix-basecc: force GAP to use gcc as the compiler name
  * debian/control, debian/doc/gap2deb:
    - Use improved Description from upstream. Closes: #637357 
  * debian/rules
    - Add -Wl,-z,relro to LDFLAGS

 -- Bill Allombert <ballombe@debian.org>  Thu, 03 Jul 2014 19:04:26 +0200

gap (4r7p4-1) unstable; urgency=low

  * New upstream release.
   + Note that gap-gdat 4r7p4 is identical to gap-gdat 4r7p3.
   + Patches applied upstream:
    - manualindex-sh: removed
    - update-convert.pl: removed
    - configure-fpic: removed
  * New patches added:
   - gap-fix-alignment: upstream patch to fix alignment issues on sparc.
   - fix-compressed-six-files: read compressed six files correctly.
   - upstream-env-tmpdir from Jerome Benoit: Honour TMPDIR. Closes: #733672

 -- Bill Allombert <ballombe@debian.org>  Fri, 28 Feb 2014 18:26:16 +0100

gap (4r7p2-1) unstable; urgency=low

  * New upstream release:
   + Patches applied upstream:
     - mips-macfloat: removed
     - hurd-task_self: removed
     - configure-abi: removed
     - configure-fpic: updated
     - configure-ncurses: removed
     - gac-object: removed
     - gac-o: removed
  * New patches added:
    - gac-itanium: Fix gac on ia64
    - manualindex-sh: add /bin/sh to doc/manualindex-sh
    - program-path: add bin to pkg installation path.
    - update-convert.pl: upstream patch to update convert.pl for current doc.
  * debian/doc:
    + gap2deb: script to generate debian directory from PackageInfo.g scripts
  * debian/control:
    - Bump Standards-Version to 3.9.5.
    - gap-dev: Add Depends on libgmp-dev. Closes: #734448. 
      Thanks Jérome Benoit.

 -- Bill Allombert <ballombe@debian.org>  Thu, 20 Feb 2014 14:23:11 +0100

gap (4r6p5-3) unstable; urgency=low

  * new patch:
     - mips-macfloat: added: workaround for an alignement issue on mips(el).
  * debian/rules:
   - build gap-dev object files with -fPIC to be compatible with use in shared
     libraries.

 -- Bill Allombert <ballombe@debian.org>  Thu, 19 Sep 2013 15:00:06 +0200

gap (4r6p5-2) unstable; urgency=low

  * debian/copyright: Bump version
  * patches:
     - configure: renamed to configure-gapdir
     - configure-abi: do not pass -m to gcc (fix FTBFS on ia64, mips and arm).
     - hurd-task_self: use mach_task_self instead of task_self on GNU/hurd.

 -- Bill Allombert <ballombe@debian.org>  Wed, 11 Sep 2013 22:32:50 +0200

gap (4r6p5-1) unstable; urgency=low

  * New upstream release. Closes: #677668.
    + Fix crashes while displaying large character tables. Closes: #605269.
    + debian/tarball, debian/README.source: update for new upstream tarball
    + debian/watch: added, for new upstream tarball
    + debian/rules: 
      - no need to add -fno-strict-aliasing to CFLAGS
  * Move to new source format 3.0 (quilt). Patches applied:
     - config-sub-guess: use autotools-dev config.* version
     - configure: fix path in configure
     - doc-makefile: add Makefile for clean/install
     - gac-object: fix OBJECTS variable in gac script
     - gac: update path in gac script
     - configure-fpic: use -fPIC instead of -fpic
     - configure-ncurses: do not require ncurses to link readline
  * debian/control:
    - Build-Depends on libgmp-dev and gap-gapdoc
    - gap-libs now depends on gap-gapdoc
    - Bump Standards-Version to 3.9.4.
  * debian/gap-core.triggers, debian/gap-core.postinst:
    - Fix to handle compressed workspaces
  * Move to debhelper 5
  * debian/rules:
    - use dh_prep instead of dh_clean -k

 -- Bill Allombert <ballombe@debian.org>  Sun, 08 Sep 2013 11:44:42 +0200

gap (4r4p12-2) unstable; urgency=low

  * debian/rules: 
    - add -fno-strict-aliasing to CFLAGS to avoid issues with newer gcc.
  * src/sysfiles.c: 
    - Prefer termios.h over sgtty.h. This fix a build failure on kfreebsd.

 -- Bill Allombert <ballombe@debian.org>  Thu, 25 Nov 2010 11:07:30 +0100

gap (4r4p12-1) unstable; urgency=low

  * New upstream release. Closes: #510823.
    - Better support for ia64 architecture.
  * debian/rules:
    - No more build with -O0 on ia64.
  * Move doc-base menu entries to Science/Mathematics. Closes: #458543.
    Thanks Marco Rodrigues.
  * debian/README.Debian: remove paragraph about upgrade from Sarge.
  * debian/gap-core.links:
    - Add symlink /usr/share/gap/sysinfo.gap -> /usr/lib/gap/sysinfo.gap
  * debian/control:
    - Bump Standards-Version to 3.8.0.
    - Move Homepage field from description to the source section.
  * debian/tarball:
    - Extract gap and tomlib versions from files in the tarballs.
  * debian/README.source: (added)
    - Document how to generate the Debian tarballs from the upstream ones.
  * debian/gap-core.triggers, debian/gap-core.postinst
    - Set up a trigger to rebuild the system GAP workspace if it exists,
      when Debian GAP packages are updated.
  * debian/doc/update-gap-workspace.1, debian/doc/gap-policy.sgml
    - Document that the system GAP workspace is automatically updated.

 -- Bill Allombert <ballombe@debian.org>  Thu, 19 Feb 2009 10:35:52 +0100

gap (4r4p10-2) unstable; urgency=low

  * Change make_doc to use #!/bin/bash to allow building with 
    /bin/sh->/bin/dash. Closes: #459064.
  * debian/copyright:
    - convert to UTF-8
  * debian/control:
    - bump Standards-Version to 3.7.3.

 -- Bill Allombert <ballombe@debian.org>  Mon, 21 Jan 2008 11:29:01 +0100

gap (4r4p10-1) unstable; urgency=low

  * New upstream release
  * Change debian/tarball script to include tools tarball in source.
  * Update menu entry section to Applications/Science/Mathematics.
  * debian/control:
    - Build-Depends on texlive-base instead of tetex-*.
    - Use ${binary:Version} instead ${Source-Version}

 -- Bill Allombert <ballombe@debian.org>  Thu, 22 Nov 2007 18:37:55 +0100

gap (4r4p9-1) unstable; urgency=low

  * New upstream release

 -- Bill Allombert <ballombe@debian.org>  Sun, 12 Nov 2006 15:49:23 +0100

gap (4r4p8-1) unstable; urgency=low

  * New upstream release
  * Bump Standard-Versions to 3.7.2
  * debian/control: 
     - Use ${source:Version} instead ${Source-Version} to allow binNMU.
     - Build-Depends on dpkg-dev (>= 1.13.19)
  * Fix whatis entries of gap(1) and update-gap-workspace(1).
  * Do not hard-code path to mrabbrev, see #359684. Thanks Frank Küster

 -- Bill Allombert <ballombe@debian.org>  Wed, 11 Oct 2006 21:39:57 +0200

gap (4r4p7-1) unstable; urgency=low

  * New upstream release
  * debian/rules: Change -X\\.pdf to -X.pdf since dh_install was fixed.
  * regenerate GAP manpage.

 -- Bill Allombert <ballombe@debian.org>  Sat, 25 Mar 2006 13:01:43 +0100

gap (4r4p6-1) unstable; urgency=low

  * New upstream release
  * sysinfo.gap: moved to gap-core
  * debian/control: gap-core replaces gap-dev sysinfo.gap file.
  * debian/README.Debian: document that some GAP packages require 
    gap-dev to build.

 -- Bill Allombert <ballombe@debian.org>  Tue, 18 Oct 2005 08:41:30 +0200

gap (4r4p5-1) unstable; urgency=low

  * New upstream release
    - This release includes lib/colorprompt.g by Frank Luebeck.
  * Update README.Debian to reflect the new instructions to set up 
    colors in gap.
  * cnf/gac.in: Remove spurious final rmdir (sigh).
  * Tighten dependencies to avoid differents parts of GAP getting 
    out of sync with each others.
  * Bump Standard-Versions to 3.6.2
  * Add icon to menu entry.

 -- Bill Allombert <ballombe@debian.org>  Fri,  1 Jul 2005 16:50:34 +0200

gap (4r4p4-1) unstable; urgency=low

  * New upstream release
  * Remove obsolete watch file.
  * Fix sections of doc-base files.
  * GAP packaging policy: Recommends to compress large datasets. 
  * README.Debian: Add sections "Browsing GAP Documentation", "Large GAP
    libraries are compressed" and "Supporting GAP".
  * Fix update-gap-workspace scripts (use gap -R).

 -- Bill Allombert <ballombe@debian.org>  Wed, 12 Jan 2005 12:09:35 +0100

gap (4r4p3-2) unstable; urgency=medium

  * gap-libs:
    + Add an empty /usr/share/gap/pkg directory. GAP would fail to 
      start without one (if no gap-pkg-* are installed).
    + Add lib/colorprompt.g by Frank Luebeck.

 -- Bill Allombert <ballombe@debian.org>  Sat, 31 Jul 2004 09:48:45 +0200

gap (4r4p3-1) unstable; urgency=low

  * New upstream release
  * Add script update-gap-workspace to build a GAP workspace to start
    GAP faster. Please read the manpage!
  * Add debian/tarball script to split upstream tarballs.
  * gac script patch was merged upstream. Thanks the GAP team.
  * debian/control:
    + Use Homepage instead of Web page in long description.
    + Bump Standard-Version to 3.6.1.0.
    + gap now Suggests: gap-table-of-marks.
  * Document update-gap-workspace in README.Debian
  * Change gap script to automatically load GAP workspace if available.
  * gap-core.menu: quote fields properly.
  * Add the gap packaging policy document to gap-doc.
  * Run a minimal test suite at build time.
  * debian/rules: call make compile, not make to avoid strip.

 -- Bill Allombert <ballombe@debian.org>  Tue, 18 May 2004 17:50:15 +0200

gap (4r3n5-1) unstable; urgency=low

  * New upstream bugfix
  * gap-doc, gap-dev: Fix section.
  * Fix gap-characters-tables --> gap-character-tables typo in Suggests:

 -- Bill Allombert <ballombe@debian.org>  Tue, 24 Jun 2003 16:05:27 +0200

gap (4r3n4-2) unstable; urgency=low

  * gap-doc: Install properly for use with SetHelpViewer and ctbllib.
  * gap-libs: Add pkg/ALLPKG for autoloading of gap packages.
  * control: Add Web page to description, remove false readline reference.
  * Simplify/fix gap script. Thanks Werner Nickel!
  * Bump Standard-Version to 3.5.10.0.
  * control: Replaces gap, not gap4.
  * control: gap Suggests gap-character-tables.
  * gap.1: Add reference to documentation of options.
  * gap-libs: Add support for compressed DVI files.
  * gap-core: Fix problems when writing files.

 -- Bill Allombert <ballombe@debian.org>  Mon, 19 May 2003 00:03:12 +0200

gap (4r3n4-1) unstable; urgency=low

  * Initial Release of GAP first GPL version, 4r3, Bugfix 4.
  * Changelog for the old non DSFG-free versions are in changelog-3.4.Debian
    and changelog-4.2.Debian.
  * New maintainer. Closes: #103406
  * New upstream version: Closes: #155648, #155652.
  * Fix typo in description. Closes: #124660. Thanks Matt Zimmerman.
  * gap-dev contains /usr/lib/gap/src/config.h Closes: #119851
  * Include files are in /usr/include/gap Closes: #119850
  * Closes: #121846 which is obsolete due to package renaming.

 -- Bill Allombert <ballombe@debian.org>  Tue, 15 Apr 2003 22:13:35 +0200