1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
include /usr/share/dpkg/default.mk
%:
dh $@
override_dh_auto_configure:
dh_auto_configure -- --with-ncl=/usr --enable-mpi
dh_auto_build
mkdir -p debian/mpi
mv src/Garli debian/mpi/Garli-mpi
make distclean
dh_auto_configure -- --with-ncl=/usr
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
cp -a tests tests.bak
find tests -name "*.conf" -exec sed -i~ 's/randseed *= *-1/randseed = 1/' \{\} \;
dh_auto_test
rm -rf tests
mv tests.bak tests
endif
|