File: control.native.in

package info (click to toggle)
gcc-defaults-mipsen 1.186.1
  • links: PTS, VCS
  • area: main
  • in suites: sid
  • size: 424 kB
  • sloc: makefile: 1,185; sh: 103
file content (347 lines) | stat: -rw-r--r-- 12,719 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347

Package: cpp
Priority: optional
Architecture: any
Section: interpreters
Multi-Arch: allowed
Depends: cpp-${pv:cpp} ${reqv:cpp}, ${misc:Depends}
Suggests: cpp-doc
Conflicts: cpp-doc (<< 1:2.95.3)
Description: GNU C preprocessor (cpp)
 The GNU C preprocessor is a macro processor that is used automatically
 by the GNU C compiler to transform programs before actual compilation.
 .
 This package has been separated from gcc for the benefit of those who
 require the preprocessor but not the compiler.
 .
 This is a dependency package providing the default GNU C preprocessor.

Package: gcc
Priority: optional
Architecture: any
Depends: cpp (= ${version:cpp}), gcc-${pv:gcc} ${reqv:gcc}, ${misc:Depends}
Recommends: libc6-dev | libc-dev
Suggests: gcc-multilib, make, manpages-dev, autoconf, automake, libtool, flex, bison, gdb, gcc-doc
Provides: c-compiler, ${gcc:triplet}
Conflicts: gcc-doc (<< 1:2.95.3)
Description: GNU C compiler
 This is the GNU C compiler, a fairly portable optimizing compiler for C.
 .
 This is a dependency package providing the default GNU C compiler.

Package: gcc-multilib
Priority: optional
Architecture: @multilib_archs@
Depends: cpp (= ${version:cpp}), gcc (= ${version:gcc}), gcc-${pv:gcc}-multilib ${reqv:gcc}, ${misc:Depends}, linux-libc-dev (>= 3.0.0-2) [linux-any]
Conflicts: gcc-4.9-alpha-linux-gnu,
  gcc-4.9-aarch64-linux-gnu,
  gcc-4.9-arm-linux-gnueabi,
  gcc-4.9-arm-linux-gnueabihf,
  gcc-4.9-hppa-linux-gnu,
  gcc-4.9-m68k-linux-gnu,
  gcc-4.9-powerpc-linux-gnu,
  gcc-4.9-powerpc-linux-gnuspe,
  gcc-4.9-powerpc64-linux-gnu,
  gcc-4.9-powerpc64le-linux-gnu,
  gcc-4.9-mips-linux-gnu,
  gcc-4.9-mipsel-linux-gnu,
  gcc-4.9-mips64-linux-gnuabi64,
  gcc-4.9-mips64el-linux-gnuabi64,
  gcc-4.9-s390x-linux-gnu,
  gcc-4.9-sh4-linux-gnu,
  gcc-4.9-sparc-linux-gnu,
  gcc-4.9-sparc64-linux-gnu,
  gcc-5-aarch64-linux-gnu,
  gcc-5-alpha-linux-gnu,
  gcc-5-arm-linux-gnueabi,
  gcc-5-arm-linux-gnueabihf,
  gcc-5-hppa-linux-gnu,
  gcc-5-m68k-linux-gnu,
  gcc-5-powerpc-linux-gnu,
  gcc-5-powerpc-linux-gnuspe,
  gcc-5-powerpc64-linux-gnu,
  gcc-5-powerpc64le-linux-gnu,
  gcc-5-mips-linux-gnu,
  gcc-5-mipsel-linux-gnu,
  gcc-5-mips64-linux-gnuabi64,
  gcc-5-mips64el-linux-gnuabi64,
  gcc-5-s390x-linux-gnu,
  gcc-5-sh4-linux-gnu,
  gcc-5-sparc-linux-gnu,
  gcc-5-sparc64-linux-gnu,
  gcc-6-aarch64-linux-gnu,
  gcc-6-alpha-linux-gnu,
  gcc-6-arm-linux-gnueabi,
  gcc-6-arm-linux-gnueabihf,
  gcc-6-hppa-linux-gnu,
  gcc-6-m68k-linux-gnu,
  gcc-6-powerpc-linux-gnu,
  gcc-6-powerpc-linux-gnuspe,
  gcc-6-powerpc64-linux-gnu,
  gcc-6-powerpc64le-linux-gnu,
  gcc-6-mips-linux-gnu,
  gcc-6-mipsel-linux-gnu,
  gcc-6-mips64-linux-gnuabi64,
  gcc-6-mips64el-linux-gnuabi64,
  gcc-6-s390x-linux-gnu,
  gcc-6-sh4-linux-gnu,
  gcc-6-sparc-linux-gnu,
  gcc-6-sparc64-linux-gnu,
  gcc-7-aarch64-linux-gnu,
  gcc-7-alpha-linux-gnu,
  gcc-7-arm-linux-gnueabi,
  gcc-7-arm-linux-gnueabihf,
  gcc-7-hppa-linux-gnu,
  gcc-7-i686-linux-gnu,
  gcc-7-m68k-linux-gnu,
  gcc-7-powerpc-linux-gnu,
  gcc-7-powerpc-linux-gnuspe,
  gcc-7-powerpc64-linux-gnu,
  gcc-7-powerpc64le-linux-gnu,
  gcc-7-mips-linux-gnu,
  gcc-7-mipsel-linux-gnu,
  gcc-7-mips64-linux-gnuabi64,
  gcc-7-mips64el-linux-gnuabi64,
  gcc-7-riscv64-linux-gnu,
  gcc-7-s390x-linux-gnu,
  gcc-7-sh4-linux-gnu,
  gcc-7-sparc-linux-gnu,
  gcc-7-x86-64-linux-gnu,
  gcc-7-x86-64-linux-gnux32,
  gcc-8-aarch64-linux-gnu,
  gcc-8-alpha-linux-gnu,
  gcc-8-arm-linux-gnueabi,
  gcc-8-arm-linux-gnueabihf,
  gcc-8-hppa-linux-gnu,
  gcc-8-i686-linux-gnu,
  gcc-8-m68k-linux-gnu,
  gcc-8-powerpc-linux-gnu,
  gcc-8-powerpc-linux-gnuspe,
  gcc-8-powerpc64-linux-gnu,
  gcc-8-powerpc64le-linux-gnu,
  gcc-8-mips-linux-gnu,
  gcc-8-mipsel-linux-gnu,
  gcc-8-mips64-linux-gnuabi64,
  gcc-8-mips64el-linux-gnuabi64,
  gcc-8-riscv64-linux-gnu,
  gcc-8-s390x-linux-gnu,
  gcc-8-sh4-linux-gnu,
  gcc-8-sparc-linux-gnu,
  gcc-8-sparc64-linux-gnu,
  gcc-8-x86-64-linux-gnu,
  gcc-8-x86-64-linux-gnux32,
  gcc-9-aarch64-linux-gnu,
  gcc-9-alpha-linux-gnu,
  gcc-9-arm-linux-gnueabi,
  gcc-9-arm-linux-gnueabihf,
  gcc-9-hppa-linux-gnu,
  gcc-9-i686-linux-gnu,
  gcc-9-m68k-linux-gnu,
  gcc-9-powerpc-linux-gnu,
  gcc-9-powerpc-linux-gnuspe,
  gcc-9-powerpc64-linux-gnu,
  gcc-9-powerpc64le-linux-gnu,
  gcc-9-mips-linux-gnu,
  gcc-9-mipsel-linux-gnu,
  gcc-9-mips64-linux-gnuabi64,
  gcc-9-mips64el-linux-gnuabi64,
  gcc-9-riscv64-linux-gnu,
  gcc-9-s390x-linux-gnu,
  gcc-9-sh4-linux-gnu,
  gcc-9-sparc-linux-gnu,
  gcc-9-sparc64-linux-gnu,
  gcc-9-x86-64-linux-gnu,
  gcc-9-x86-64-linux-gnux32,
  gcc-10-aarch64-linux-gnu,
  gcc-10-alpha-linux-gnu,
  gcc-10-arm-linux-gnueabi,
  gcc-10-arm-linux-gnueabihf,
  gcc-10-hppa-linux-gnu,
  gcc-10-i686-linux-gnu,
  gcc-10-m68k-linux-gnu,
  gcc-10-powerpc-linux-gnu,
  gcc-10-powerpc-linux-gnuspe,
  gcc-10-powerpc64-linux-gnu,
  gcc-10-powerpc64le-linux-gnu,
  gcc-10-mips-linux-gnu,
  gcc-10-mipsel-linux-gnu,
  gcc-10-mips64-linux-gnuabi64,
  gcc-10-mips64el-linux-gnuabi64,
  gcc-10-riscv64-linux-gnu,
  gcc-10-s390x-linux-gnu,
  gcc-10-sh4-linux-gnu,
  gcc-10-sparc-linux-gnu,
  gcc-10-sparc64-linux-gnu,
  gcc-10-x86-64-linux-gnu,
  gcc-10-x86-64-linux-gnux32,
Description: GNU C compiler (multilib files)
 This is the GNU C compiler, a fairly portable optimizing compiler for C.
 .
 A dependency package on architectures with multilib support; the package
 contains dependencies for the non-default multilib architecture(s).

Package: g++
Priority: optional
Architecture: any
Depends: cpp (= ${version:cpp}), gcc (= ${version:cpp}), g++-${pv:gpp} ${reqv:gpp}, gcc-${pv:gpp} ${reqv:gpp}, ${misc:Depends}
Suggests: ${pkgmulti:gpp}
Provides: c++-compiler, ${gpp:triplet}
Description: GNU C++ compiler
 This is the GNU C++ compiler, a fairly portable optimizing compiler for C++.
 .
 This is a dependency package providing the default GNU C++ compiler.

Package: g++-multilib
Priority: optional
Architecture: @multilib_archs@
Depends: cpp (= ${version:cpp}), gcc-multilib (= ${version:cpp}), g++ (= ${version:cpp}), g++-${pv:gpp}-multilib ${reqv:gpp}, ${misc:Depends}
Description: GNU C++ compiler (multilib files)
 This is the GNU C++ compiler, a fairly portable optimizing compiler for C++.
 .
 A dependency package on architectures with multilib support; the package
 contains dependencies for the non-default multilib architecture(s).

Package: gobjc
Priority: optional
Architecture: any
Depends: cpp (>= ${version:cpp}), gcc (>= ${version:cpp}), gobjc-${pv:gobjc} ${reqv:gobjc}, ${misc:Depends}
Suggests: ${pkgmulti:gobjc}
Provides: objc-compiler
Description: GNU Objective-C compiler
 This is the GNU Objective-C compiler, which compiles Objective-C on platforms
 supported by the gcc compiler. It uses the gcc backend to generate optimized
 code.
 .
 This is a dependency package providing the default GNU Objective-C compiler.

Package: gobjc-multilib
Priority: optional
Architecture: @multilib_archs@
Depends: cpp (>= ${version:cpp}), gcc-multilib (>= ${version:cpp}), gobjc (>= ${version:gcc}), gobjc-${pv:gobjc}-multilib ${reqv:gobjc}, ${misc:Depends}
Description: GNU Objective-C compiler (multilib files)
 This is the GNU Objective-C compiler, which compiles Objective-C on
 platforms supported by the gcc compiler.
 .
 A dependency package on architectures with multilib support; the package
 contains dependencies for the non-default multilib architecture(s).

Package: gobjc++
Priority: optional
Architecture: any
Depends: cpp (>= ${version:cpp}), gcc (>= ${version:cpp}), gobjc++-${pv:gobjcxx} ${reqv:gobjcxx}, ${misc:Depends}
Recommends: g++ (>= ${version:cpp}), gobjc (>= ${version:cpp})
Suggests: ${pkgmulti:gobjcxx}
Provides: objc++-compiler
Description: GNU Objective-C++ compiler
 This is the GNU Objective-C++ compiler, which compiles
 Objective-C++ on platforms supported by the gcc compiler. It uses the
 gcc backend to generate optimized code.
 .
 This is a dependency package providing the default GNU Objective-C++ compiler.

Package: gobjc++-multilib
Priority: optional
Architecture: @multilib_archs@
Depends: cpp (>= ${version:cpp}), gobjc-multilib (>= ${version:cpp}), gobjc++ (>= ${version:gcc}), gobjc++-${pv:gobjcxx}-multilib ${reqv:gobjcxx}, ${misc:Depends}
Description: GNU Objective-C++ compiler (multilib files)
 This is the GNU Objective-C++ compiler, which compiles Objective-C++ on
 platforms supported by the gcc compiler.
 .
 A dependency package on architectures with multilib support; the package
 contains dependencies for the non-default multilib architecture(s).

Package: gfortran
Priority: optional
Architecture: any
Depends: cpp (= ${version:cpp}), gcc (= ${version:gcc}), gfortran-${pv:gfort} ${reqv:gfort}, ${misc:Depends}
Suggests: ${pkgmulti:gfort}, gfortran-doc
Provides: fortran-compiler, ${fortran:mod-version}
Description: GNU Fortran 95 compiler
 This is the GNU Fortran 95 compiler, which compiles Fortran 95 on platforms
 supported by the gcc compiler. It uses the gcc backend to generate optimized
 code.
 .
 This is a dependency package providing the default GNU Fortran 95 compiler.

Package: gfortran-multilib
Priority: optional
Architecture: @multilib_archs@
Depends: cpp (= ${version:cpp}), gcc-multilib (= ${version:cpp}), gfortran (= ${version:gcc}), gfortran-${pv:gfort}-multilib ${reqv:gfort}, ${misc:Depends}
Description: GNU Fortran 95 compiler (multilib files)
 This is the GNU Fortran compiler, which compiles Fortran 95 on platforms
 supported by the gcc compiler.
 .
 A dependency package on architectures with multilib support; the package
 contains dependencies for the non-default multilib architecture(s).

Package: gccgo
Priority: optional
Architecture: any
Depends: cpp (>= ${version:cpp}), gcc (>= ${version:gcc}), gccgo-${pv:ggo} ${reqv:ggo}, ${misc:Depends}
Suggests: ${pkgmulti:ggo}
Provides: go-compiler
Description: Go compiler, based on the GCC backend
 This is the GNU Go compiler, which compiles Go on platforms supported by
 the gcc compiler. It uses the gcc backend to generate optimized code.
 .
 This is a dependency package providing the default GNU Go compiler.

Package: gccgo-multilib
Priority: optional
Architecture: @go_multilib_archs@
Depends: cpp (>= ${version:cpp}), gcc-multilib (>= ${version:cpp}), gccgo (>= ${version:ggo}), gccgo-${pv:ggo}-multilib ${reqv:ggo}, ${misc:Depends}
Description: Go compiler, based on the GCC backend (multilib files)
 This is the GNU Go compiler, which compiles Go on platforms supported by
 the gcc compiler. It uses the gcc backend to generate optimized code.
 .
 A dependency package on architectures with multilib support; the package
 contains dependencies for the non-default multilib architecture(s).

Package: gdc
Priority: optional
Architecture: any
Depends: gdc-${pv:gdc} ${reqv:gdc}, ${dep:libgphobos}, ${misc:Depends}
Replaces: gdc-4.1 (<< 0.25-4.1.2-18), gdc-4.2 (<< 0.25-4.2.2-7), gdc-4.3 (<< 1:1.043-4.3.4-1)
Description: D compiler (language version 2), based on the GCC backend
 This is a dependency package providing the default D compiler.
 Per policy, all packages that contain D sources must use this package
 in their Build-Depends line.
 .
 This compiler supports D language version 2.

Package: gdc-multilib
Priority: optional
Architecture: @d_multilib_archs@
Depends: cpp (>= ${version:cpp}), gcc-multilib (>= ${version:cpp}), gdc (>= ${version:gcc}), gdc-${pv:gdc}-multilib ${reqv:gdc}, ${misc:Depends}
Description: D compiler (language version 2) (multilib files)
 This compiler supports D language version 2.
 .
 A dependency package on architectures with multilib support; the package
 contains dependencies for the non-default multilib architecture(s).

Package: libgphobos-dev
Section: libdevel
Priority: optional
Architecture: any
Multi-Arch: same
Depends: libgphobos-${pv:gdc}-dev ${reqv:gdc}, ${misc:Depends}
Provides: libphobos-dev
Description: Phobos D standard library
 This is a dependency package providing the default D standard library.

Package: gm2
Priority: optional
Architecture: any
Depends: cpp (>= ${version:cpp}), gcc (>= ${version:gcc}), gm2-${pv:gm2} ${reqv:gm2}, ${misc:Depends}
Description: GNU Modula-2 compiler, based on the GCC backend
 This is a dependency package providing the default GNU Modula-2 compiler.

#Package: gm2-multilib
#Priority: optional
#Architecture: @m2_multilib_archs@
#Depends: cpp (>= ${version:cpp}), gcc-multilib (>= ${version:cpp}), gm2 (>= ${version:gcc}), gm2-${pv:gdc}-multilib ${reqv:gm2}, ${misc:Depends}
#Description: GNU Modula-2 compiler (multilib files)
# This is a dependency package providing the default GNU Modula-2 compiler.
# .
# A dependency package on architectures with multilib support; the package
# contains dependencies for the non-default multilib architecture(s).