1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,-z,defs -Wl,--as-needed
include /usr/share/dpkg/architecture.mk
ifneq (,$(filter libgdk-pixbuf2.0-doc,$(shell dh_listpackages)))
BUILD_DOCS:=-Dgtk_doc=true
else
BUILD_DOCS:=-Dgtk_doc=false
endif
%:
dh $@ --with gir,gnome
override_dh_auto_configure:
cp -a debian/invalid-colors.gif tests/test-images/gif-test-suite/invalid-colors.gif
dh_auto_configure -- \
$(BUILD_DOCS) \
-Dinstalled_tests=true \
-Dintrospection=enabled \
$(NULL)
mimedir := debian/build-mime
mimexml := /usr/share/mime/packages/freedesktop.org.xml
infiles := \
libgdk-pixbuf-2.0-0.triggers \
libgdk-pixbuf-2.0-0.postinst \
libgdk-pixbuf-2.0-0.postrm
override_dh_auto_test:
ifeq ($(filter nocheck,$(DEB_BUILD_OPTIONS)),)
ifneq (,$(filter $(DEB_HOST_ARCH),kfreebsd-amd64))
meson test --print-errorlogs -C $(CURDIR)/obj-$(DEB_HOST_GNU_TYPE) -t 5 --no-suite=flaky || true
else
meson test --print-errorlogs -C $(CURDIR)/obj-$(DEB_HOST_GNU_TYPE) -t 5 --no-suite=flaky
endif
endif
override_dh_install:
dh_install
set -e; for file in $(infiles); do \
sed -e"s/#MULTIARCH#/$(DEB_HOST_MULTIARCH)/g" \
debian/$${file}.in > debian/$$file; \
done
mkdir -p $(mimedir)/packages
[ -f $(mimexml) ]
xsltproc -nonet debian/keep-png-only.xsl $(mimexml) \
> $(mimedir)/packages/png.freedesktop.org.xml
update-mime-database $(mimedir)
install -m 0644 -D $(mimedir)/mime.cache debian/libgdk-pixbuf-2.0-0-udeb/usr/share/mime/mime.cache
mkdir -p debian/libgdk-pixbuf-2.0-0-udeb/usr/lib/$(DEB_HOST_MULTIARCH)/gdk-pixbuf-2.0/2.10.0
LD_LIBRARY_PATH=debian/libgdk-pixbuf-2.0-0-udeb/usr/lib:$(LD_LIBRARY_PATH) \
debian/libgdk-pixbuf-2.0-0/usr/lib/$(DEB_HOST_MULTIARCH)/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders \
debian/libgdk-pixbuf-2.0-0-udeb/usr/lib/$(DEB_HOST_MULTIARCH)/gdk-pixbuf-2.0/2.10.0/loaders/*.so \
| sed 's;$(CURDIR)/debian/libgdk-pixbuf-2.0-0-udeb;;g' \
> debian/libgdk-pixbuf-2.0-0-udeb/usr/lib/$(DEB_HOST_MULTIARCH)/gdk-pixbuf-2.0/2.10.0/loaders.cache
chmod 0644 debian/libgdk-pixbuf-2.0-0-udeb/usr/lib/$(DEB_HOST_MULTIARCH)/gdk-pixbuf-2.0/2.10.0/loaders.cache
override_dh_makeshlibs-arch:
dh_makeshlibs -plibgdk-pixbuf-2.0-0 --add-udeb=libgdk-pixbuf-2.0-0-udeb -X "/usr/lib/$(DEB_HOST_MULTIARCH)/gdk-pixbuf-2.0" -V -- -c4
dh_makeshlibs --remaining-packages -V -- -c4
override_dh_missing:
dh_missing --fail-missing
override_dh_clean:
dh_clean
set -e; for file in $(infiles); do \
rm -f debian/$$file; \
done
rm -rf $(mimedir)
override_dh_builddeb:
NO_PNG_PKG_MANGLE=1 dh_builddeb -pgdk-pixbuf-tests
dh_builddeb --remaining-packages
override_dh_strip_nondeterminism:
dh_strip_nondeterminism -Xinstalled-tests
|