1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37
|
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/default.mk
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
%:
dh $@ --with sphinxdoc
override_dh_auto_configure:
dh_auto_configure -- --enable-jobserver=no --disable-silent-rules
override_dh_auto_install:
chrpath -d bin/gearadmin gearmand/gearmand
dh_auto_install
override_dh_sphinxdoc:
dh_sphinxdoc
rm -rf debian/libgearman-doc/usr/share/doc/libgearman-doc/html/_sources
override_dh_missing:
dh_missing --fail-missing -X.la
override_dh_auto_test:
|