1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84
|
export CONFIG_FLAGS="--prefix=/usr"
build: build-stamp
build-stamp:
dh_testdir
QUILT_PATCHES=debian/patches quilt push -a || test $$? = 2
touch configure.in \
&& touch aclocal.m4 \
&& touch configure \
&& touch config.h.in \
&& touch `find . -name Makefile.in`
./configure --prefix=/usr --mandir=$${prefix}/share/man \
--infodir=$${prefix}/share/info
$(MAKE)
touch build-stamp
clean:
dh_testdir
dh_testroot
rm -f build-stamp
[ ! -f Makefile ] || $(MAKE) distclean
QUILT_PATCHES=debian/patches quilt pop -a -R || test $$? = 2
rm -rf .pc
dh_clean
install: build
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs var/games usr/share/games/
$(MAKE) install DESTDIR=`pwd`/debian/geki2/
mv `pwd`/debian/geki2/usr/bin `pwd`/debian/geki2/usr/games
cp `pwd`/debian/geki2.xpm \
`pwd`/debian/geki2/usr/share/games/geki2/geki2.xpm
rm -f `pwd`/debian/geki2/usr/share/games/geki2/data/.score
binary-indep: build install
binary-arch: build install
dh_testdir
dh_testroot
dh_installdocs README
dh_installmenu
dh_installman debian/geki2.6
dh_installchangelogs ChangeLog
dh_link
dh_strip
dh_compress
dh_fixperms
dh_makeshlibs
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install
|