1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139
|
export DH_OPTIONS
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
CFLAGS = -Wall -g
INSTALL_DIR=$(CURDIR)/debian/tmp
PERL_ARCHLIB := $(shell perl -MConfig -e 'print $$Config{vendorarch}')
configure: configure-stamp
configure-stamp:
dh_testdir
ifneq "$(wildcard /usr/share/misc/config.sub)" ""
cp -f /usr/share/misc/config.sub config/config.sub
endif
ifneq "$(wildcard /usr/share/misc/config.guess)" ""
cp -f /usr/share/misc/config.guess config/config.guess
endif
CFLAGS="$(CFLAGS) -Wl,-z,defs" \
dh_autoreconf
dh_auto_configure -- \
--with-extension-destdir=$(INSTALL_DIR) \
--with-perl-vendor-arch \
--without-python-extensions \
--without-java-extensions
touch configure-stamp
build: build-arch
build-arch: build-arch-stamp
build-arch-stamp: configure-stamp
dh_auto_build
touch build-arch-stamp
build-indep:
clean:
dh_testdir
dh_testroot
dh_auto_clean
rm -f *-stamp
rm -f config/config.sub config/config.guess
dh_autoreconf_clean
dh_clean
install: install-indep install-arch
install-indep:
install-arch: build-arch-stamp
dh_testdir
dh_testroot
dh_prep -s
dh_installdirs -s
dh_auto_install
binary-common:
dh_testdir
dh_testroot
dh_installchangelogs ChangeLog
dh_installdocs
dh_installexamples
dh_installman
dh_install --sourcedir=$(INSTALL_DIR)
dh_link
ifndef $(NOSTRIP)
dh_strip
endif
dh_compress
dh_fixperms
chmod 644 $(CURDIR)/debian/libgenders-perl/usr/share/perl5/gendlib.pl
chmod 644 $(CURDIR)/debian/libgenders-perl/usr/share/perl5/hostlist.pl
chrpath -d $(CURDIR)/debian/libgenders-perl$(PERL_ARCHLIB)/auto/Libgenders/Libgenders.so
chrpath -d $(CURDIR)/debian/genders/usr/bin/nodeattr
dh_perl -plibgenders-perl
dh_makeshlibs
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary-indep: build-indep install-indep
binary-arch: build-arch install-arch binary-common
binary: binary-arch binary-indep
.PHONY: build clean binary-indep binary-arch binary install install-indep install-arch
|