File: changelog

package info (click to toggle)
ghc-mod 5.6.0.0-2
  • links: PTS, VCS
  • area: main
  • in suites: stretch
  • size: 1,216 kB
  • ctags: 240
  • sloc: haskell: 8,323; lisp: 1,557; makefile: 40; sh: 34
file content (263 lines) | stat: -rw-r--r-- 7,571 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
ghc-mod (5.6.0.0-2) unstable; urgency=medium

  * Upload to unstable as part of GHC 8 transition.

 -- Clint Adams <clint@debian.org>  Thu, 27 Oct 2016 18:32:17 -0400

ghc-mod (5.6.0.0-1) experimental; urgency=medium

  * New upstream version.

 -- Clint Adams <clint@debian.org>  Fri, 07 Oct 2016 19:26:52 -0400

ghc-mod (5.5.0.0-1) unstable; urgency=medium

  [ Dmitry Bogatov ]
  * Use secure (https) uri in Vcs-Git field in 'debian/control'
  * Bump standards version to 3.9.8 (no changes needed)

  [ Joachim Breitner ]
  * New upstream release

 -- Joachim Breitner <nomeata@debian.org>  Sat, 28 May 2016 13:29:32 +0200

ghc-mod (5.4.0.0-1) unstable; urgency=medium

  * New upstream release
     Can be built with GHC 7.10 (Closes: #809088, 809159)

 -- Sven Bartscher <sven.bartscher@weltraumschlangen.de>  Fri, 25 Dec 2015 13:12:43 +0100

ghc-mod (5.3.0.0-4) unstable; urgency=medium

  * Switch Vcs-Git/Vcs-Browser headers to new location.

 -- Clint Adams <clint@debian.org>  Thu, 03 Dec 2015 14:54:02 -0500

ghc-mod (5.3.0.0-3) experimental; urgency=medium

  [ Joachim Breitner ]
  * Add Uploaders field, which I accidentally dropped
  * Fix typo in Build-Depends 

  [ Sven Bartscher ]
  * Drop unnecessary Build-Depends

 -- Sven Bartscher <sven.bartscher@weltraumschlangen.de>  Tue, 29 Sep 2015 19:31:36 +0200

ghc-mod (5.3.0.0-2) experimental; urgency=medium

  * Add lintian override for spurious rpaths

 -- Joachim Breitner <nomeata@debian.org>  Thu, 20 Aug 2015 15:03:50 +0200

ghc-mod (5.3.0.0-1) experimental; urgency=low

  [ Sven Bartscher ]
  * New upstream release

  [ Joachim Breitner ]
  * Depend on haskell-devscripts >= 0.10 to ensure that this package
    builds against GHC in experimental

 -- Joachim Breitner <nomeata@debian.org>  Thu, 20 Aug 2015 10:26:53 +0200

ghc-mod (5.2.1.2-1) unstable; urgency=medium

  * New upstream release (Closes: #785936)

 -- Joachim Breitner <nomeata@debian.org>  Sun, 05 Apr 2015 18:57:40 +0200

ghc-mod (5.2.1.1-4) experimental; urgency=medium

  * Depend on haskell-devscripts 0.9, found in experimental
  * Do not depend on transformers, which now comes with GHC

 -- Joachim Breitner <nomeata@debian.org>  Sat, 20 Dec 2014 20:31:30 +0100

ghc-mod (5.2.1.1-3) unstable; urgency=medium

  * Remove unnecessary dependency on emacsen-common from ghc-mod.
    (Closes: #767762)
  * Make ghc-mod-el depend on the same version of ghc-mod so nothing breaks in
    case the interface changes.

 -- Daniel Gröber <dxld@darkboxed.org>  Sun, 09 Nov 2014 15:06:08 +0100

ghc-mod (5.2.1.1-2) unstable; urgency=medium

  * Fix upgrading ghc-mod from wheezy by declaring a Replaces+Breaks relation
    for ghc-mod-el. (Closes: #768226)

 -- Daniel Gröber <dxld@darkboxed.org>  Thu, 06 Nov 2014 17:42:36 +0100

ghc-mod (5.2.1.1-1) unstable; urgency=medium

  * New upstream release
  * Split off ghc-mod-el (Closes: #767762)

 -- Daniel Gröber <dxld@darkboxed.org>  Mon, 03 Nov 2014 23:18:16 +0100

ghc-mod (4.1.2-2) unstable; urgency=medium

  * Added conformance to emacs policy
  * Declared incompability with emacs23 (Closes: #752594)

 -- Sven Bartscher <sven.bartscher@weltraumschlangen.de>  Thu, 26 Jun 2014 16:47:02 +0200

ghc-mod (4.1.2-1) unstable; urgency=high

  * Added depenency on ghc (Closes: #714458)
  * Bump standards version, no change
  * New upstream release

 -- Sven Bartscher <sven.bartscher@weltraumschlangen.de>  Thu, 29 May 2014 00:14:54 +0200

ghc-mod (3.1.4-1) unstable; urgency=low

  [ Joachim Breitner ]
  * Adjust watch file to new hackage layout

  [ Kiwamu Okabe ]
  * New upstream version.

 -- Kiwamu Okabe <kiwamu@debian.or.jp>  Thu, 05 Dec 2013 18:54:46 +0900

ghc-mod (3.0.2-1) unstable; urgency=low

  * New upstream version.

 -- Kiwamu Okabe <kiwamu@debian.or.jp>  Mon, 16 Sep 2013 20:47:53 +0900

ghc-mod (2.0.2-2) unstable; urgency=low

  * Adjust debian/rules to new path used by haskell-devscripts (Closes:
    #719403)

 -- Joachim Breitner <nomeata@debian.org>  Mon, 12 Aug 2013 11:03:00 +0200

ghc-mod (2.0.2-1) unstable; urgency=low

  * New upstream version 2.0.2.

 -- Kiwamu Okabe <kiwamu@debian.or.jp>  Wed, 29 May 2013 22:02:56 +0900

ghc-mod (1.11.1-2) unstable; urgency=low

  * Enable compat level 9

 -- Joachim Breitner <nomeata@debian.org>  Fri, 24 May 2013 12:49:44 +0200

ghc-mod (1.11.1-1) experimental; urgency=low

  * Depend on haskell-devscripts 0.8.13 to ensure this packages is built
    against experimental
  * Bump standards version, no change
  * New upstream release

 -- Joachim Breitner <nomeata@debian.org>  Fri, 19 Oct 2012 23:50:34 +0200

ghc-mod (1.11.0-1) unstable; urgency=low

  * Imported Upstream version 1.11.0.

 -- Kiwamu Okabe <kiwamu@debian.or.jp>  Mon, 06 Aug 2012 20:46:26 +0900

ghc-mod (1.10.18-1) unstable; urgency=low

  * Imported Upstream version 1.10.18.

 -- Kiwamu Okabe <kiwamu@debian.or.jp>  Sun, 24 Jun 2012 14:03:57 +0900

ghc-mod (1.10.15-1) unstable; urgency=low

  * Imported Upstream version 1.10.15.

 -- Kiwamu Okabe <kiwamu@debian.or.jp>  Sat, 21 Apr 2012 16:45:51 +0900

ghc-mod (1.10.13-1) unstable; urgency=low

  * Imported Upstream version 1.10.13.

 -- Kiwamu Okabe <kiwamu@debian.or.jp>  Sun, 15 Apr 2012 08:50:05 +0900

ghc-mod (1.10.10-2) unstable; urgency=low

  * /etc/emacs/site-start.d/51ghc-mod.el:
    + remove haskell-mode-hook to use ghc-mod's C-cC-t.

 -- Kiwamu Okabe <kiwamu@debian.or.jp>  Sun, 04 Mar 2012 23:27:48 +0900

ghc-mod (1.10.10-1) unstable; urgency=low

  * Imported Upstream version 1.10.10.
  * Add new build-dependencies:
    + libghc-ghc-syb-utils-dev
    + libghc-io-choice-dev
    + libghc-syb-dev
  * Drop obsolete build-dependency:
    + libghc-attoparsec-dev
    + libghc-attoparsec-enumerator-dev
    + libghc-enumerator-dev
  * Set source/format: 3.0 (quilt)

 -- Kiwamu Okabe <kiwamu@debian.or.jp>  Sun, 04 Mar 2012 14:48:58 +0900

ghc-mod (1.0.5-1) unstable; urgency=low

  * Imported Upstream version 1.0.5.
  * Build-Depends: ghc-ghci (bacause ghc-mod use ghci's API)

 -- Kiwamu Okabe <kiwamu@debian.or.jp>  Wed, 28 Dec 2011 15:44:14 +0900

ghc-mod (1.0.4-2) unstable; urgency=low

  * Add missing BD on libghc-regex-posix-dev and specify version constraint on
    attoparsec from control file. Thanks to Micah Gersten for the patch
    (Closes: #653204)

 -- Iain Lane <laney@debian.org>  Sun, 25 Dec 2011 13:30:19 +0000

ghc-mod (1.0.4-1) unstable; urgency=low

  * Imported Upstream version 1.0.4
  * Support attoparsec 0.10. (Closes: #652240)
  * Change vcs line to darcs on debian/control.

 -- Kiwamu Okabe <kiwamu@debian.or.jp>  Thu, 22 Dec 2011 14:29:31 +0900

ghc-mod (1.0.0-1) unstable; urgency=low

  * Imported Upstream version 1.0.0
  * Build-Depends: libghc-filemanip-dev

 -- Kiwamu Okabe <kiwamu@debian.or.jp>  Thu, 24 Nov 2011 17:58:21 +0900

ghc-mod (0.6.1-1) unstable; urgency=low

  * Imported Upstream version 0.6.1

 -- Kiwamu Okabe <kiwamu@debian.or.jp>  Wed, 31 Aug 2011 20:16:25 +0900

ghc-mod (0.6.0-3) unstable; urgency=low

  * depend on haskell-mode.
  * not support xemacs*. (Closes: #639649)

 -- Kiwamu Okabe <kiwamu@debian.or.jp>  Mon, 29 Aug 2011 12:03:10 +0900

ghc-mod (0.6.0-2) unstable; urgency=low

  * NMU.
  * Minor cleanup before sponsoring (version bump required because 0.6.0-1 was
    already tagged in git repository).
  * Add watch file

 -- Joachim Breitner <nomeata@debian.org>  Sun, 28 Aug 2011 10:47:17 +0200

ghc-mod (0.6.0-1) UNRELEASED; urgency=low

  * ITP (Closes: #639553)
  * Debianization generated by cabal-debian

 -- Kiwamu Okabe <kiwamu@debian.or.jp>  Fri, 26 Aug 2011 23:00:21 +0900