File: rules

package info (click to toggle)
gimp 2.10.18-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 225,636 kB
  • sloc: ansic: 815,922; makefile: 12,059; python: 7,782; cpp: 7,042; lisp: 5,507; sh: 4,562; perl: 3,805; xml: 1,484; yacc: 588; lex: 342
file content (47 lines) | stat: -rwxr-xr-x 1,239 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
#!/usr/bin/make -f

export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,--as-needed

ifeq (yes,$(shell dpkg-vendor --derives-from Ubuntu && echo yes))
	BUGTRACKER = https://bugs.launchpad.net/ubuntu/+source/gimp/+filebug?no-redirect
else
	BUGTRACKER = https://www.debian.org/Bugs/Reporting
endif

%:
	dh $@

# Don't switch to Multi-Arch yet because of potential incompatibility with
# third-party add-ons
override_dh_auto_configure:
	dh_auto_configure -- \
		--libdir=/usr/lib \
		--libexecdir=/usr/lib/gimp \
		--disable-static \
		--disable-python \
		--disable-check-update \
		--enable-default-binary \
		--enable-gtk-doc \
		--without-appdata-test \
		--without-webkit \
		--without-xvfb-run \
		--with-bug-report-url=$(BUGTRACKER)

override_dh_autoreconf:
	dh_autoreconf --as-needed

# exclude since we manually add the Suggests in debian/control
override_dh_shlibdeps:
	dh_shlibdeps -Xusr/lib/gimp/2.0/modules/libcontroller-midi.so \
		-Llibgimp2.0 -l$(CURDIR)/debian/libgimp2.0/usr/lib

override_dh_makeshlibs:
	dh_makeshlibs -X/usr/lib/gimp/2.0/modules -- -c4

override_dh_install:
	find debian/tmp -name '*.la' -print -delete
	dh_install

override_dh_missing:
	dh_missing --fail-missing