File: user-guide.sgml

package info (click to toggle)
glade-nonus 0.6.4-5
  • links: PTS
  • area: main
  • in suites: woody
  • size: 12,152 kB
  • ctags: 3,879
  • sloc: ansic: 54,332; sh: 6,839; makefile: 743; sed: 93
file content (1384 lines) | stat: -rw-r--r-- 36,599 bytes parent folder | download | duplicates (3)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
436
437
438
439
440
441
442
443
444
445
446
447
448
449
450
451
452
453
454
455
456
457
458
459
460
461
462
463
464
465
466
467
468
469
470
471
472
473
474
475
476
477
478
479
480
481
482
483
484
485
486
487
488
489
490
491
492
493
494
495
496
497
498
499
500
501
502
503
504
505
506
507
508
509
510
511
512
513
514
515
516
517
518
519
520
521
522
523
524
525
526
527
528
529
530
531
532
533
534
535
536
537
538
539
540
541
542
543
544
545
546
547
548
549
550
551
552
553
554
555
556
557
558
559
560
561
562
563
564
565
566
567
568
569
570
571
572
573
574
575
576
577
578
579
580
581
582
583
584
585
586
587
588
589
590
591
592
593
594
595
596
597
598
599
600
601
602
603
604
605
606
607
608
609
610
611
612
613
614
615
616
617
618
619
620
621
622
623
624
625
626
627
628
629
630
631
632
633
634
635
636
637
638
639
640
641
642
643
644
645
646
647
648
649
650
651
652
653
654
655
656
657
658
659
660
661
662
663
664
665
666
667
668
669
670
671
672
673
674
675
676
677
678
679
680
681
682
683
684
685
686
687
688
689
690
691
692
693
694
695
696
697
698
699
700
701
702
703
704
705
706
707
708
709
710
711
712
713
714
715
716
717
718
719
720
721
722
723
724
725
726
727
728
729
730
731
732
733
734
735
736
737
738
739
740
741
742
743
744
745
746
747
748
749
750
751
752
753
754
755
756
757
758
759
760
761
762
763
764
765
766
767
768
769
770
771
772
773
774
775
776
777
778
779
780
781
782
783
784
785
786
787
788
789
790
791
792
793
794
795
796
797
798
799
800
801
802
803
804
805
806
807
808
809
810
811
812
813
814
815
816
817
818
819
820
821
822
823
824
825
826
827
828
829
830
831
832
833
834
835
836
837
838
839
840
841
842
843
844
845
846
847
848
849
850
851
852
853
854
855
856
857
858
859
860
861
862
863
864
865
866
867
868
869
870
871
872
873
874
875
876
877
878
879
880
881
882
883
884
885
886
887
888
889
890
891
892
893
894
895
896
897
898
899
900
901
902
903
904
905
906
907
908
909
910
911
912
913
914
915
916
917
918
919
920
921
922
923
924
925
926
927
928
929
930
931
932
933
934
935
936
937
938
939
940
941
942
943
944
945
946
947
948
949
950
951
952
953
954
955
956
957
958
959
960
961
962
963
964
965
966
967
968
969
970
971
972
973
974
975
976
977
978
979
980
981
982
983
984
985
986
987
988
989
990
991
992
993
994
995
996
997
998
999
1000
1001
1002
1003
1004
1005
1006
1007
1008
1009
1010
1011
1012
1013
1014
1015
1016
1017
1018
1019
1020
1021
1022
1023
1024
1025
1026
1027
1028
1029
1030
1031
1032
1033
1034
1035
1036
1037
1038
1039
1040
1041
1042
1043
1044
1045
1046
1047
1048
1049
1050
1051
1052
1053
1054
1055
1056
1057
1058
1059
1060
1061
1062
1063
1064
1065
1066
1067
1068
1069
1070
1071
1072
1073
1074
1075
1076
1077
1078
1079
1080
1081
1082
1083
1084
1085
1086
1087
1088
1089
1090
1091
1092
1093
1094
1095
1096
1097
1098
1099
1100
1101
1102
1103
1104
1105
1106
1107
1108
1109
1110
1111
1112
1113
1114
1115
1116
1117
1118
1119
1120
1121
1122
1123
1124
1125
1126
1127
1128
1129
1130
1131
1132
1133
1134
1135
1136
1137
1138
1139
1140
1141
1142
1143
1144
1145
1146
1147
1148
1149
1150
1151
1152
1153
1154
1155
1156
1157
1158
1159
1160
1161
1162
1163
1164
1165
1166
1167
1168
1169
1170
1171
1172
1173
1174
1175
1176
1177
1178
1179
1180
1181
1182
1183
1184
1185
1186
1187
1188
1189
1190
1191
1192
1193
1194
1195
1196
1197
1198
1199
1200
1201
1202
1203
1204
1205
1206
1207
1208
1209
1210
1211
1212
1213
1214
1215
1216
1217
1218
1219
1220
1221
1222
1223
1224
1225
1226
1227
1228
1229
1230
1231
1232
1233
1234
1235
1236
1237
1238
1239
1240
1241
1242
1243
1244
1245
1246
1247
1248
1249
1250
1251
1252
1253
1254
1255
1256
1257
1258
1259
1260
1261
1262
1263
1264
1265
1266
1267
1268
1269
1270
1271
1272
1273
1274
1275
1276
1277
1278
1279
1280
1281
1282
1283
1284
1285
1286
1287
1288
1289
1290
1291
1292
1293
1294
1295
1296
1297
1298
1299
1300
1301
1302
1303
1304
1305
1306
1307
1308
1309
1310
1311
1312
1313
1314
1315
1316
1317
1318
1319
1320
1321
1322
1323
1324
1325
1326
1327
1328
1329
1330
1331
1332
1333
1334
1335
1336
1337
1338
1339
1340
1341
1342
1343
1344
1345
1346
1347
1348
1349
1350
1351
1352
1353
1354
1355
1356
1357
1358
1359
1360
1361
1362
1363
1364
1365
1366
1367
1368
1369
1370
1371
1372
1373
1374
1375
1376
1377
1378
1379
1380
1381
1382
1383
1384
<!DOCTYPE Book PUBLIC "-//OASIS//DTD DocBook V4.0//EN"[
<!ENTITY version "0.57"> 
]>

<!-- INDEX -->

<book id="index">

  <bookinfo> 
    <title>Glade - Manuale di riferimento</title>

    <copyright>
      <year>2000</year>
      <holder>Michael Vance</holder>
    </copyright>

    <legalnotice>
     <para>
      � permesso copiare, distribuire e/o modificare questo documento 
      secondo i termini della <citetitle>GNU Free Documentation
      License</citetitle>, Versione 1.1 o qualsiasi altra versione
      successiva pubblicata dalla Free Software Foundation, senza
      Sezioni non modificabili, senza nessun Testo Copertina e senza nessun
      Testo di retro copertina. � possibile ottenere una copia della
      <citetitle>GNU Free Documentation License</citetitle> dalla Free
      Software Foundation visitando <ulink url="http://www.fsf.org/"
      type="http">il loro sito web</ulink> oppure scrivendo a:
      Free Software Foundation, Inc., 59 Temple Place - Suite 330,
      Boston, MA 02111-1307, USA.
     </para>
     <para>
      Molti dei nomi usati dalle compagnie per identificare i loro prodotti
      e servizi sono dichiarati marchi registrati. Quando tali nomi appaiono
      in un qualsiasi documento GNOME, e qualora tali nomi siano noti ai
      membri dello GNOME Documentation Project, essi vengono stampati in
      maiuscolo o con iniziali maiuscole.
     </para>
    </legalnotice>

    <releaseinfo> 
      Prima versione del Manuale di riferimento di Glade.
    </releaseinfo>

  </bookinfo>

<!-- INTRODUCTION -->

  <chapter id="introduction">
    <title>Introduzione</title> 
    
    <para>
      Glade � un'applicazione per creare interfacce utente grafiche che 
      fanno uso delle librerie Gtk+ e GNOME.
      Glade vi permette di sviluppare rapidamente tali interfacce ed �
      in grado di creare il codice sorgente in diversi linguaggi che
      costruiranno le interfacce per voi.
      Glade pu� anche essere usato, insieme a libglade, per creare le 
      interfacce utente dinamicamente, dal file di descrizione XML
      che crea Glade stesso.
    </para>

    <para>
      Glade pu� essere preso <ulink
      url="http://glade.gnome.org/download.html" type="http">qui</ulink>.
      Ci sono dei link per i vari formati di pacchetto. Glade � anche 
      disponibile sul server CVS di GNOME. Per maggiori informazioni 
      su come prendere Glade dal CVS vedete la <ulink
       url="http://developer.gnome.org/tools/cvs.html" type="http">
       pagina GNOME CVS</ulink>.
    </para>

    <para>
      Per usare il supporto a GNOME di Glade dovete avere una versione
      molto recente di GNOME, oppure dovete compilare Glade con
      <command>--disable-gnome</command>.
    </para>

    <para>
      Una volta installato, Glade pu� essere avviato dalla riga di
      comando battendo <command>glade</command>.
    </para>

  </chapter>

<!-- USING --> 

  <chapter id="using">
    <title>Usare Glade</title>

    <para>
      Glade � composto da diverse finestre, ognuna delle quali serve ad
      un preciso scopo. La finestra principale contiene il menu, la
      barra degli strumenti e un elenco delle finestre di primo livello.
      La palette elenca i vari oggetti che � possibile usare per costruire 
      l'interfaccia. L'editor delle propriet� permette di modificare le 
      propriet� dei widget, come la dimensione, il colore, le maschere 
      dei segnali, ecc.
    </para>

    <para>
      Tipicamente un progetto Glade inizia con la costruzione della
      interfaccia utente. Usando la palette componete ed inserite widget
      fino a che non ottenete l'interfaccia desiderata; nel far ci�
      sarete soliti usare l'editor delle propriet� per manipolare le
      diverse impostazioni di raggruppamento, le dimensioni dei widget,
      ecc.
    </para>

    <para> 
      Terminata l'interfaccia salverete il progetto e creerete i file
      sorgente in C che verranno usati per generare l'interfaccia utente.
      Quindi segue la fase di integrazione della logica del vostro progetto.
      Alcune altre cose che potete fare:
    </para>

    <itemizedlist>
      <listitem>
	<para>
	  usare libgade per costruire l'interfaccia
	</para>
      </listitem>
      <listitem>
	<para>
	  usare Glade per impostare i gestori di segnale dei vostri widget
	</para>
      </listitem>
      <listitem>
	<para>
	  emettere il codice in Perl o in Eiffel piuttosto che in C
	</para>
      </listitem>
    </itemizedlist>

    <para>
      Le diverse parti di Glade verranno descritte in dettaglio nelle
      sezioni seguenti.
    </para>

  </chapter>

<!-- MENUS -->

  <chapter id="menus">
    <title>Menu</title>

    <figure>
      <title>I menu di Glade</title>
      <screenshot>
	<graphic fileref="user-guide-images/menu" format="png" srccredit="mkv">
      </screenshot>
    </figure>

    <sect1 id="file-menu">
      <title>Il menu File</title>

      <figure>
	<title>menu File</title>
	<screenshot>
	  <graphic fileref="user-guide-images/file-menu" format="png" srccredit="mkv">
	</screenshot>
      </figure>

      <sect2 id="file-new-project">
	<title>Nuovo progetto</title>

	<para>
	  Crea un nuovo progetto Glade. Glade vi chieder� conferma; se
	  non avete salvato un progetto aperto, scegliete 
	  <command>Annulla</command> e salvatelo, altrimenti scegliete
	  <command>OK</command>.
        </para>

      </sect2>

      <sect2 id="file-open-project">
	<title>Apri</title>

	<para>
	  Apre un progetto Glade esistente. Apparir� una finestra di 
	  dialogo Gtk+ standard in cui � possibile indicare il file del 
	  progetto. Osservate che le finestre di dialogo Gtk+ di apertura 
	  di file permettono, nel campo in cui va inserito il nome del file,
	  il completamento del nome tramite tasto tab.
        </para>

      </sect2>

      <sect2 id="file-save-project">
	<title>Salva</title>

	<para>
	  Salva il vostro progetto. Se � la prima volta che salvate il
	  progetto corrente apparir� la finestra di dialogo Opzioni
	  del progetto, in cui i vari campi conterranno dei valori
	  predefiniti. Se invece in passato avevate gi� specificato
	  tali opzioni del progetto, Glade salver� semplicemente il
	  vostro progetto senza fare commenti.
	</para>

      </sect2>

      <sect2 id="file-build-source-code">
	<title>Genera codice sorgente</title>

	<para>
	  Genera il codice sorgente desiderato (C, Perl, Ada, ecc.).
	  Se non avete mai salvato il progetto corrente apparir� la 
	  finestra di dialogo Opzioni del progetto, in cui i vari campi 
	  conterranno dei valori predefiniti. Se invece in passato 
	  avevate gi� specificato tali opzioni, Glade generer� il 
	  codice sorgente senza fare commenti.
	</para>
      </sect2>

      <sect2 id="file-project-options">
	<title>Opzioni del progetto</title>

	<para>
	  La finestra di dialogo Opzioni del progetto � descritta
          <link linkend="project-options">qui</link>.
	</para>

      </sect2>

      <sect2 id="exit-menu">
	<title>Esci</title>

	<para>
	  Esce da Glade. Attualmente Glade non chiede se deve salvare un
	  progetto che non � stato salvato (sebbene chieda conferma
	  per uscire); quindi ricordatevi di salvare il vostro progetto
	  prima di uscire.
	</para>

      </sect2>

    </sect1> <!-- File menu -->

    <sect1 id="edit-menu">
      <title>Il menu Modifica</title>

      <figure>
	<title>menu Modifica</title>
	<screenshot>
	  <graphic fileref="user-guide-images/edit-menu" 
	  format="png" srccredit="mkv">
	</screenshot>
      </figure>

      <sect2 id="edit-cut">
	<title>Taglia</title>

	<para>
	  Rimuove un widget e lo mette negli appunti.
	</para>

      </sect2>

      <sect2 id="edit-copy">
	<title>Copia</title>

	<para>
	  Copia un widget negli appunti. Il widget originale
	  rimane al suo posto.
	</para>

      </sect2>

      <sect2 id="edit-paste">
	<title>Incolla</title>

	<para>
	  Se negli appunti c'� un widget, questo viene copiato
	  nella selezione.
	</para>

      </sect2>

      <sect2 id="edit-clear">
	<title>Cancella</title>

	<para>
	  Rimuove il widget selezionato senza spostarlo negli appunti.
	</para>

      </sect2>

    </sect1> <!-- Edit menu -->

    <sect1 id="view-menu">
      <title>Il menu Vista</title>

      <figure>
	<title>Menu Vista</title>
	<screenshot>
	  <graphic fileref="user-guide-images/view-menu" 
	  format="png" srccredit="mkv">
	</screenshot>
      </figure>

      <!-- FIXME: Link. -->

      <sect2 id="view-palette">
	<title>Mostra Palette</title>

	<para>
	  Mostra la palette, se era nascosta, oppure la porta in primo
	  piano se era visibile ma coperta.
	</para>

      </sect2>

      <sect2 id="view-property-editor">
	<title>Mostra Editor delle propriet�</title>

	<para>
	  Mostra la finestra di dialogo delle propriet�, se era 
	  nascosta, oppure la porta in primo piano se era visibile ma 
	  coperta.
	</para>

      </sect2>

      <sect2 id="view-widget-tree">
	<title>Mostra Albero dei widget</title>

	<para>
	  Mostra la finestra di dialogo con l'albero dei widget, se era 
	  nascosta, oppure la porta in primo piano se era visibile ma 
	  coperta.
	</para>

      </sect2>

      <sect2 id="view-clipboard">
	<title>Mostra Appunti</title>

	<para>
	  Mostra gli appunti con i widget, se erano nascosti, oppure li
	  porta in primo piano se erano visibili ma coperti.
	</para>

      </sect2>

    </sect1> <!-- View menu -->

    <sect1 id="settings-menu">
      <title>Il menu Opzioni</title>

      <figure>
	<title>Menu Opzioni</title>
	<screenshot>
	  <graphic fileref="user-guide-images/settings-menu" 
	  format="png" srccredit="mkv">
	</screenshot>
      </figure>

      <sect2 id="settings-show-grid">
	<title>Mostra griglia</title>

	<para>
	  Glade deve mostrare una griglia, per facilitare l'allineamanto
	  dei widget quando li si mette in un contenitore GtkFixed?
	</para>

      </sect2>

      <sect2 id="settings-snap-to-grid">
	<title>Aggancia alla griglia</title>

	<para>
	  Volete che Glade agganci i widget alla griglia quando li
	  posizionate in un contenitore GtkFixed?
	</para>

      </sect2>

      <sect2 id="settings-show-widget-tooltips">
	<title>Mostra Suggerimenti dei widget</title>

	<para>
	  Quando il puntatore indugia su un widget, deve essere mostrato 
	  un suggerimento che descrive quel particolare widget?
	</para>

      </sect2>

      <sect2 id="settings-grid-options">
	<title>Opzioni della griglia</title>

	<figure>
	  <title>Opzioni griglia</title>
	  <screenshot>
	    <graphic fileref="user-guide-images/grid-options" format="png"
             srccredit="mkv">
	  </screenshot>
	</figure>

	<itemizedlist>
	  <listitem>
	    <para>
	      Spaziatura orizzontale: numero di pixel da saltare,
	      orizzontalmente, prima di tracciare una linea.
	    </para>
	  </listitem>
	  <listitem>
	    <para>
	      Spaziatura verticale: numero di pixel da saltare, 
	      verticalmente, prima di tracciare una linea.
	    </para>
	  </listitem>
	  <listitem>
	    <para>
	      Stile griglia: la griglia deve essere tracciata con
	      una serie di puntini o con delle linee?
	    </para>
	  </listitem>
        </itemizedlist>

      </sect2>

      <sect2 id="settings-snap-options">
	<title>Opzioni di aggancio</title>

	<figure>
	  <title>Opzioni di aggancio</title>
	  <screenshot>
	    <graphic fileref="user-guide-images/snap-options" format="png"
            srccredit="mkv">
	  </screenshot>
	</figure>

	<itemizedlist>
	  <listitem>
	    <para>
	      Aggancio orizzontale: Glade deve agganciare alla griglia il 
	      bordo sinistro e/o destro di un widget?
	    </para>
	  </listitem>
	  <listitem>
	    <para>
	      Aggancio verticale: Glade deve agganciare alla griglia il 
	      bordo superiore e/o inferiore di un widget?
	    </para>
	  </listitem>
	</itemizedlist>

      </sect2>

    </sect1> <!-- Settings menu -->

    <sect1 id="help-menu">
      <title>Il menu Aiuto</title>

      <figure>
	<title>Menu Aiuto</title>
	<screenshot>
	  <graphic fileref="user-guide-images/help-menu" 
	  format="png" srccredit="mkv">
	</screenshot>
      </figure>

      <sect2 id="help-about">
	<title>Informazioni su...</title>

	<para>
	  Visualizza la finestra di dialogo Informazioni su, che
	  mostra il logo di Glade, gli autori e informazioni per contattare
	  il Team di Glade.
	</para>

      </sect2>

    </sect1> <!-- Help menu -->

    <sect1 id="toolbar">
      <title>La barra degli strumenti</title>

      <figure>
	<title>Barra degli strumenti</title>
	<screenshot>
	  <graphic fileref="user-guide-images/toolbar" 
	  format="png" srccredit="mkv">
	</screenshot>
      </figure>

      <sect2 id="toolbar-open">
	<title>Apri</title>

	<para>
	  Corrisponde a <link linkend="file-open-project">
          <command>File:Apri</command></link>.
	</para>

      </sect2>

      <sect2 id="toolbar-save">
	<title>Salva</title>

	<para>
	  Corrisponde a <link linkend="file-save-project">
          <command>File:Salva</command></link>.
	</para>

      </sect2>

      <sect2 id="toolbar-options">
	<title>Opzioni</title>

	<para>
	  Corrisponde a <link linkend="file-project-options">
          <command>File:Opzioni progetto</command></link>.
	</para>

      </sect2>

      <sect2 id="toolbar-build">
	<title>Crea sorgente</title>

	<para>
	  Corrisponde a <link linkend="file-build-source-code">
          <command>File:Genera codice sorgente</command></link>.
	</para>

      </sect2>

    </sect1> <!-- Toolbar -->

  </chapter> <!-- Menus -->

<!-- PROJECTOPTIONS -->

  <chapter id="project-options">
    <title>Opzioni del progetto</title>

    <sect1 id="project-options-general">
      <title>Generale</title>

      <figure>
	<title>Opzioni generali</title>
	<screenshot>
	  <graphic fileref="user-guide-images/options-general" format="png"
           srccredit="mkv">
	</screenshot>
      </figure>

      <sect2 id="project-options-general-basic">
	<title>Opzioni principali</title>

	<variablelist>

	  <varlistentry>
	    <term>Directory del progetto</term>
	    <listitem>
	      <para>
	        La directory in cui si trovano i progetti Glade.
		Potete sceglierla usando una finestra di dialogo per
		la selezione di file, richiamabile cliccando su 
                <command>Sfoglia</command>.
	      </para>
	    </listitem>
	  </varlistentry>

	  <varlistentry>
	    <term>Nome del progetto</term>
	    <listitem>
	      <para>
	        Il nome del vostro progetto. Modificandolo cambieranno
		il nome del progetto e quello del file contenente il
		progetto.
	      </para>
	    </listitem>
	  </varlistentry>

	  <varlistentry>
	    <term>Nome dell'applicazione</term>
	    <listitem>
	      <para>
	        Il nome dell'eseguibile che verr� generato da Glade
		per il vostro progetto. Modificandolo il nome del
		file del progetto cambier� automaticamente.
	      </para>
	    </listitem>
	  </varlistentry>

	  <varlistentry>
	    <term>File del progetto</term>
	    <listitem>
	      <para>
	        Il nome del file del progetto Glade. E' il file in cui
		verranno memorizzate tutte le informazioni riguardanti
		il vostro progetto.
	      </para>
	    </listitem>
	  </varlistentry>

	</variablelist>

      </sect2> <!-- Basic options -->

      <sect2 id="project-options-general-subdirs">
	<title>Sottodirectory</title>

	<variablelist>
	  <varlistentry>
	    <term>Directory dei sorgenti</term>
	    <listitem>
	      <para>
                La directory in cui Glade metter� il suo codice sorgente
		(quando gli verr� detto di farlo).
	      </para>
	    </listitem>
	  </varlistentry>

	  <varlistentry>
	    <term>Directory delle immagini</term>
	    <listitem>
	      <para>
	        La directory in cui Glade cercher� tutte le immagini 
		usate nel progetto.
	      </para>
	    </listitem>
	  </varlistentry>

	</variablelist>

      </sect2> <!-- Subdirectories -->

      <sect2 id="project-options-general-language">
	<title>Linguaggio</title>

	<!-- FIXME: per-language description? -->

	<para>
	  Selezionate il linguaggio di programmazione in cui Glade
	  scriver� il codice. Al momento della scrittura di questo
	  documento le opzioni possibili sono: C, C++, Ada95, Perl
	  ed Eiffel.
	</para>

      </sect2> <!-- Language -->

      <sect2>
	<title>GNOME</title>

	<para>
	  Glade deve scrivere codice che usa le librerie GNOME?
	</para>

      </sect2>

    </sect1> <!-- General options -->

    <sect1>
      <title>Opzioni C</title>

      <figure>
	<title>Opzioni C</title>
	<screenshot>
	  <graphic fileref="user-guide-images/options-c" 
	  format="png" srccredit="mkv">
	</screenshot>
      </figure>

      <sect2 id="proejct-options-c-general">
	<title>Opzioni generali</title>

	<variablelist>

	  <varlistentry>
	    <term>Supporto per Gettext</term>
	    <listitem>
	      <para>
	        Glade deve scrivere codice che supporti lo GNU gettext
		per l'internazionalizzazione?
	      </para>
	    </listitem>
	  </varlistentry>

	  <varlistentry>
	    <term>Imposta nomi dei widget</term>
	    <listitem>
	      <para>
	        Glade deve scrivere nel codice i nomi di tutti i widget?
		Questa opzione � utile se avete intenzione di usare le
		chiamate Gtk+ come <function>gtk_widget_path()</function>. 
		Vedete anche <function>gtk_widget_set_name()</function>.
	      </para>
	    </listitem>
	  </varlistentry>

	  <varlistentry>
	    <term>Crea copie di backup dei file sorgente</term>
	    <listitem>
	      <para>
	        Glade deve creare delle copie di backup di tutti i vostri
		file sorgente quando ne create di nuovi?
	      </para>
	    </listitem>
	  </varlistentry>

	</variablelist>

      </sect2>

      <sect2 id="proejct-options-c-file">
	<title>Opzioni File in uscita</title>

	<variablelist>

	  <varlistentry>
	    <term>Crea file <filename>main.c</filename></term>
	    <listitem>
	      <para>
	        Glade deve creare un file <filename>main.c</filename>
		contenente un semplice codice d'inizializzazione?
		Se avete abilitato il supporto per GNOME, allora 
		chiamer� <function>gnome_init()</function>, altimenti 
		chiamer� <function>gtk_init()</function>.
	      </para>
	    </listitem>
	  </varlistentry>

	  <varlistentry>
	    <term>Crea Funzioni di supporto</term>
	    <listitem>
	      <para>
	        Glade deve creare il file <filename>support.c</filename>,
		contenente delle funzioni di servizio per compiti quali
		la creazione di immagini, o la ricerca di un widget noto
		il nome?
	      </para>
	    </listitem>
	  </varlistentry>

	  <varlistentry>
	    <term>Crea file di supporto per la compilazione</term>
	    <listitem>
	      <para>
	        Glade deve creare dei file utili per supportare la 
		configurazione del vostro progetto tramite automake/autoconf?
		Abilitando questa opzione verranno creati diversi file:
	      </para>
	      <simplelist>
		<member><filename>AUTHORS</filename>: File per registrare i
		nomi dei collaboratori.</member>
		<member><filename>ChangeLog</filename>: File con il log delle
		modifiche da voi fatte al progetto.</member>
		<member><filename>Makefile.am</filename>: template del 
		progetto per Automake.</member>
		<member><filename>NEWS</filename>: Annunci delle nuove 
		versioni rilasciate al pubblico.</member>
		<member><filename>README</filename>: Informazioni generiche
		sul progetto.</member>
		<member><filename>acconfig.h</filename>: Definisce i simboli
		predefiniti del preprocessore per autoconf.</member>
		<member><filename>autogen.sh</filename>: Script per la
		creazione di uno script di configurazione.</member>
		<member><filename>configure.in</filename>: Template per la
		scrittura di uno script configure.</member>
		<member><filename>macros/</filename>: Directory contenente
		le macro di automake per Glade, GNOME, etc.</member>
		<member><filename>stamp-h.in</filename>: File 
		Timestamp.</member>
		<member><filename>src/Makefile.am</filename>: Template di
		automake per la directory src/.</member>
	      </simplelist>
	    </listitem>
	  </varlistentry>

	</variablelist>

      </sect2>

      <sect2 id="proejct-options-c-interface">
	<title>Funzioni di creazione dell'interfaccia</title>

	<variablelist>

	  <varlistentry>
	    <term>File sorgente</term>
	    <listitem>
	      <para>
	        Memorizza in questo file il codice che genera l'interfaccia
		utente.
	      </para>
	    </listitem>
	  </varlistentry>

	  <varlistentry>
	    <term>Nome file header</term>
	    <listitem>
	      <para>
	        Quando scrive il codice che serve a generare 
		l'interfaccia utente, memorizza in questo file i 
		prototipi di funzione, ecc.
	      </para>
	    </listitem>
	  </varlistentry>

	</variablelist>

      </sect2>

      <sect2 id="proejct-options-c-signal">
	<title>Gestori di segnale e funzioni di callback</title>

	<variablelist>

	  <varlistentry>
	    <term>File sorgente</term>
	    <listitem>
	      <para>
	        Memorizza in questo file il codice dei gestori di segnale.
	      </para>
	    </listitem>
	  </varlistentry>

	  <varlistentry>
	    <term>Nome file header</term>
	    <listitem>
	      <para> 
	        Quando scrive il codice dei gestori di segnale,
	        memorizza in questo file i prototipi di funzione, ecc.
	      </para>
	    </listitem>
	  </varlistentry>

	</variablelist>

      </sect2>

      <sect2 id="proejct-options-c-support">
	<title>Funzioni di supporto</title>

	<variablelist>

	  <varlistentry>
	    <term>File sorgente</term>
	    <listitem>
	      <para>
	        Memorizza in questo file il codice delle funzioni di supporto.
	      </para>
	    </listitem>
	  </varlistentry>

	  <varlistentry>
	    <term>Nome file header</term>
	    <listitem>
	      <para>
	        Quando scrive il codice delle funzioni di supporto,
	        memorizza in questo file i prototipi di funzione, ecc.
	      </para>
	    </listitem>
	  </varlistentry>

	</variablelist>

      </sect2>

    </sect1> <!-- C Options -->

    <sect1>
      <title>Opzioni per LibGlade</title>

      <figure>
	<title>Opzioni per LibGlade</title>
	<screenshot>
	  <graphic fileref="user-guide-images/options-libglade" format="png"
           srccredit="mkv">
	</screenshot>
      </figure>

      <sect2 id="project-options-libglade-trans">
	<title>Salva le stringhe traducibili</title>

	<para>
	  Se volete permettere l'internazionalizzazione della 
	  vostra applicazione e volete usare libglade per costruirne 
	  l'interfaccia, allora probabilemte vorrete che le stringhe
	  traducibili siano salvate in un file. Se � cos� abilitate
	  questa opzione per dirlo a Glade.
	</para>

      </sect2>

    </sect1> <!-- Libglade options -->

  </chapter> <!-- Project options -->

<!-- WINDOWS -->

  <chapter id="windows">
    <title>Finestre</title>

    <sect1 id="windows-main">
      <title>Finestra principale</title>

      <figure>
	<title>Finestra principale</title>
	<screenshot>
	  <graphic fileref="user-guide-images/window-main" format="png"
           srccredit="mkv">
	</screenshot>
      </figure>

      <sect2 id="windows-main-menu">
	<title>Menu</title>

	<para>
          I menu sono descritti <link linkend="menus">qui</link>.
        </para>

      </sect2>

      <sect2 id="windows-main-toolbar">
	<title>Barra degli strumenti</title>

	<para>
          La barra degli strumenti � descritta <link linkend="toolbar">
          qui</link>.
        </para>

      </sect2>

      <sect2 id="windows-main-list">
	<title>Elenco delle finestre di primo livello</title>

	<para>
	  La finestra principale mostra un elenco delle finestre di
	  primo livello, Gtk+ o GNOME, che sono definite nel progetto
	  corrente. Vengono incluse:
	</para>

	<itemizedlist>
	  <listitem>
	   <para><structname>GtkWindow</structname></para>
	  </listitem>
	  <listitem>
	   <para><structname>GtkDialog</structname></para>
	  </listitem>
	  <listitem>
	   <para><structname>GtkFileSelection</structname></para>
	  </listitem>
	  <listitem>
	   <para><structname>GtkColorSelectionDialog</structname></para>
	  </listitem>
	  <listitem>
	   <para><structname>GtkFontSelectionDialog</structname></para>
	  </listitem>
	  <listitem>
	   <para><structname>GtkInputDialog</structname></para>
	  </listitem>
	  <listitem>
	   <para><structname>GnomeApp</structname></para>
	  </listitem>
	  <listitem>
	   <para><structname>GnomeDialog</structname></para>
	  </listitem>
	  <listitem>
	   <para><structname>GnomeMessageBox</structname></para>
	  </listitem>
	  <listitem>
	   <para><structname>GnomeAbout</structname></para>
	  </listitem>
	  <listitem>
	   <para><structname>GnomePropertyBox</structname></para>
	  </listitem>
	</itemizedlist>

      </sect2>

    </sect1>

    <sect1 id="windows-palette">
      <title>Palette</title>

      <para>
        La palette consente di prendere i widget che si vogliono
	aggiungere al progetto Glade corrente. La palette ha tre 
	modi d'uso fondamentali. Il primo modo � la selezione, e pu� 
	essere usato cliccando sulla grande freccia nera contraddistinta
	dall'etichetta "Selettore". In questa modalit�, cliccando con
	il mouse, potete selezionare i widget gi� esistenti nel vostro
	progetto, in modo da poterli modificare usando l'editor delle
	propriet�. Il modo "selezione" � anche indicato dal puntatore
	a freccia.
      </para>

      <para>
        Il secondo modo d'uso � quello di posizionamento dei widget.
	Selezionando un widget (la maggior parte delle volte) Glade
	trasforma il puntatore in una croce e vi permette di posizionare
	il widget scelto all'interno di contenitori, widget di primo
	livello, ecc. Dopo aver posizionato il widget Glade torna in
	modo selezione.
      </para>

      <para>
        Il terzo modo d'uso � il posizinamento di primo livello.
	Selezionando dalla palette alcuni <link
	linkend="windows-main-list">widget di primo livello</link>,
	questi appariranno istantaneamente sul desktop, pronti per
	essere modificati. Questo modo � differente dal solito modo
	di posizionamento dei widget. Dopo aver selezionato un widget
	di primo livello, si torna automaticamente al modo di selezione.
      </para>

      <para>
        Nella palette i widget sono raggruppati in tre sezioni distinte:
	Gtk+ Basic, Gtk+ Additional e Gnome. La categoria Gtk+ Basic
	contiene i widget Gtk+ usati pi� spesso, come 
        <structname>GtkWindow</structname>, <structname>GtkLabel</structname>,
	ecc. Gtk+ Additional contiene widget come 
        <structname>GtkAlignment</structname>, 
	<structname>GtkPacker</structname> e
        <structname>GtkCalendar</structname>. 
	La categoria Gnome comprende tutti widget GNOME supportati da Glade.
      </para>

      <para>
        Qui sotto � riportata una lista di tutti i widget supportati.
	Per capire esattamente cos'� un certo widget nella palette 
	(cio� quando la figura che lo rappresenta non � chiara) potete
	indugiare con il puntatore sopra al widget in questione per
	veder apparire un suggerimento che lo descrive.
      </para>

      <sect2 id="windows-palette-basic">
	<title>Gtk+ Basic</title>

	<para>

	  <inlinemediaobject>
	    <imageobject>
	      <imagedata fileref="user-guide-images/window-palette-basic.png">
	    </imageobject>
	  </inlinemediaobject>

          <table>
	    <title>Gtk+ Basic</title>
	    <tgroup cols="5" align="left">
	      <tbody>
		<row>
		  <entry>
		  </entry>
		</row>
		<row>
		  <entry><structname>GtkWindow</structname></entry>
		  <entry><structname>GtkMenuBar</structname></entry>
		  <entry><structname>GtkToolbar</structname></entry>
		  <entry><structname>GtkHandleBox</structname></entry>
		</row>
		<row>
		  <entry><structname>GtkLabel</structname></entry>
		  <entry><structname>GtkEntry</structname></entry>
		  <entry><structname>GtkCombo</structname></entry>
		  <entry><structname>GtkText</structname></entry>
		</row>
		<row>
		  <entry><structname>GtkButton</structname></entry>
		  <entry><structname>GtkToggleButton</structname></entry>
		  <entry><structname>GtkCheckButton</structname></entry>
		  <entry><structname>GtkRadioButton</structname></entry>
		</row>
		<row>
		  <entry><structname>GtkList</structname></entry>
		  <entry><structname>GtkTree</structname></entry>
		  <entry><structname>GtkCList</structname></entry>
		  <entry><structname>GtkCTree</structname></entry>
		</row>
		<row>
		  <entry><structname>GtkOptionMenu</structname></entry>
		  <entry><structname>GtkSpinButton</structname></entry>
		  <entry><structname>GtkProgressBar</structname></entry>
		  <entry><structname>GtkStatusbar</structname></entry>
		</row>
		<row>
		  <entry><structname>GtkHSeparator</structname></entry>
		  <entry><structname>GtkVSeparator</structname></entry>
		  <entry><structname>GtkPixmap</structname></entry>
		  <entry><structname>GtkDrawingArea</structname></entry>
		</row>
		<row>
		  <entry><structname>GtkDialog</structname></entry>
		  <entry><structname>GtkFileSelection</structname></entry>
		  <entry><structname>GtkColorSelectionDialog</structname></entry>
		  <entry><structname>GtkFontSelectionDialog</structname></entry>
		</row>
		<row>
		  <entry><structname>GtkHBox</structname></entry>
		  <entry><structname>GtkVBox</structname></entry>
		  <entry><structname>GtkTable</structname></entry>
		  <entry><structname>GtkFixed</structname></entry>
		</row>
		<row>
		  <entry><structname>GtkHButtonBox</structname></entry>
		  <entry><structname>GtkVButtonBox</structname></entry>
		  <entry><structname>GtkHPaned</structname></entry>
		  <entry><structname>GtkVPaned</structname></entry>
		</row>
		<row>
		  <entry><structname>GtkNotebook</structname></entry>
		  <entry><structname>GtkFrame</structname></entry>
		  <entry><structname>GtkScrolledWindow</structname></entry>
		  <entry><structname>GtkViewport</structname></entry>
		</row>
	      </tbody>
	    </tgroup>
	  </table>

        </para>

      </sect2>

      <sect2 id="windows-palette-add">
	<title>Gtk+ Additional</title>

	<para>

          <inlinemediaobject>
	    <imageobject>
	      <imagedata fileref="user-guide-images/window-palette-add.png">
	    </imageobject>
	  </inlinemediaobject>

	  <table>
	    <title>Gtk+ Additional</title>
	    <tgroup cols="4" align="left">
	      <tbody>
		<row>
		  <entry><structname>GtkHScale</structname></entry>
		  <entry><structname>GtkVScale</structname></entry>
		  <entry><structname>GtkHRuler</structname></entry>
		  <entry><structname>GtkVRuler</structname></entry>
		</row>
		<row>
		  <entry><structname>GtkAlignment</structname></entry>
		  <entry><structname>GtkEventBox</structname></entry>
		  <entry><structname>GtkAccelLabel</structname></entry>
		  <entry><structname>GtkCalendar</structname></entry>
		</row>
		<row>
		  <entry><structname>GtkLayout</structname></entry>
		  <entry><structname>GtkPacker</structname></entry>
		  <entry><structname>GtkAspectFrame</structname></entry>
		  <entry><structname>GtkPopopMenu</structname></entry>
		</row>
		<row>
		  <entry><structname>GtkCurve</structname></entry>
		  <entry><structname>GtkGammaCurve</structname></entry>
		  <entry><structname>GtkHScrollbar</structname></entry>
		  <entry><structname>GtkVScrollbar</structname></entry>
		</row>
		<row>
		  <entry><structname>GtkImage</structname></entry>
		  <entry><structname>GtkPreview</structname></entry>
		  <entry><structname>GtkColorSelection</structname></entry>
		  <entry><structname>GtkFontSelection</structname></entry>
		</row>
		<row>
		  <entry><structname>GtkInputDialog</structname></entry>
		  <entry>Widget personalizzate</entry>
		  <entry><structname>GtkArrow</structname></entry>
		</row>
	      </tbody>
	    </tgroup>
	  </table>

        </para>

      </sect2>

      <sect2 id="windows-palette-gnome">
	<title>GNOME</title>

	<para>

	  <inlinemediaobject>
	    <imageobject>
	      <imagedata fileref="user-guide-images/window-palette-gnome.png">
	    </imageobject>
	  </inlinemediaobject>

	  <table>
	    <title>Gnome</title>

	    <tgroup cols="4" align="left">
	      <tbody>
		<row>
		  <entry><structname>GnomeApp</structname></entry>
		  <entry><structname>GnomeDialog</structname></entry>
		  <entry><structname>GnomeMessageBox</structname></entry>
		  <entry><structname>GnomeAbout</structname></entry>
		</row>
		<row>
		  <entry><structname>GnomeColorPicker</structname></entry>
		  <entry><structname>GnomeFontPicker</structname></entry>
		  <entry><structname>GnomeIconEntry</structname></entry>
		  <entry><structname>GnomeHRef</structname></entry>
		</row>
		<row>
		  <entry><structname>GnomeEntry</structname></entry>
		  <entry><structname>GnomeFileEntry</structname></entry>
		  <entry><structname>GnomeNumberEntry</structname></entry>
		  <entry><structname>GnomePixmapEntry</structname></entry>
		</row>
		<row>
		  <entry><structname>GnomeDateEdit</structname></entry>
		  <entry><structname>GtkDial</structname></entry>
		  <entry><structname>GtkClock</structname></entry>
		  <entry><structname>GnomeAppBar</structname></entry>
		</row>
		<row>
		  <entry><structname>GnomeCalculator</structname></entry>
		  <entry><structname>GnomeLess</structname></entry>
		  <entry><structname>GnomePaperSelector</structname></entry>
		  <entry><structname>GnomeSpell</structname> (deprecato)</entry>
		</row>
		<row>
		  <entry><structname>GnomeCanvas</structname></entry>
		  <entry><structname>GnomeIconList</structname></entry>
		  <entry><structname>GnomeIconSelection</structname></entry>
		  <entry><structname>GnomePropertyBox</structname></entry>
		</row>
		<row>
		  <entry><structname>GnomeDruid</structname></entry>
		  <entry><structname>GnomePixmap</structname></entry>
		  <entry><structname>GnomeAnimator</structname></entry>
		</row>
	      </tbody>
	    </tgroup>
	  </table>

	</para>

      </sect2>

    </sect1> <!-- Palette -->

    <sect1 id="windows-editor">
      <title>Editor delle propriet�</title>

      <para>
        FIXME
      </para>

    </sect1>

    <sect1 id="windows-tree">
      <title>Albero dei widget</title>

      <para>
        FIXME
      </para>

    </sect1>

    <sect1 id="windows-clipboard">
      <title>Appunti</title>

      <para>
        FIXME
      </para>

    </sect1>

  </chapter> <!-- Windows -->

<!-- OUTPUT -->

  <chapter id="output">
    <title>Output</title>

    <para>
      Per favore scrivimi.
    </para>

  </chapter>

<!-- LIBGLADE -->

  <chapter id="libglade">
    <title>Libglade</title>

    <para>
      Per favore scrivimi.
    </para>

 </chapter>

<!-- QUICKSTART -->

  <chapter id="quickstart">
    <title>Quick Start</title>

    <para>
      Per favore scrivimi.
    </para>

  </chapter>

<!-- HELLOWORLD -->

  <chapter id="helloworld">
    <title>Ciao mondo - Un semplice progetto</title>

    <para>
      Per favore scrivimi.
    </para>

  </chapter>

<!-- AUTHORS -->

  <chapter id="authors">
    <title>Autori</title>

    <para>
      Glade � stato scritto da Damon Chaplin
      <email>glade@glade.gnome.org</email>. Per maggiori informazioni su
      Glade, visitate la <ulink url="http://glade.gnome.org/" 
      type="http">pagina web</ulink> di glade.
    </para>

    <para>
      Per favore, mandate commenti, suggerimenti e rapporti sui bug 
      alla mailing list di Glade. Informazioni su come iscriversi a
      questa lista si possono trovare in <ulink
      url="http://glade.gnome.org/lists.html" type="http">questa
      pagina</ulink>.
    </para>

    <para>
      Questo manuale di riferimento � curato da Michael Vance
      <email>briareos@lokigames.com</email>. Inviate commenti,
      suggerimenti e rapporti sui bug, riguardanti questo manuale,
      al suo indirizzo.
    </para>

    <para>
     Traduzione italiana di Fabrizio Stefani
     (<email>fstef@it.gnome.org</email>). Per favore, inviate commenti 
     e suggerimenti riguardanti questa traduzione al suddetto indirizzo.
    </para>

    <para>

      <variablelist>
	<title>Contributi</title>

        <varlistentry>
	  <term>Ray Barker <email>fatray@home.com</email></term>
	  <listitem>
	    <para>
	      Ha contribuito con la finestra di dialogo dei menu e
	      con la documentazione sui file di output.
            </para>
	  </listitem>
        </varlistentry>

	<varlistentry>
	  <term>
            Paul J. Drongowski <email>pjd@ives.lkg.dec.com</email>
          </term>
	  <listitem>
	    <para>
	      Ha contribuito con la guida "quick start".
            </para>
	  </listitem>
	</varlistentry>

      </variablelist>
    </para>

    <para>
      Potete anche aggiungere i vostri commenti online usando la
      <ulink type="http" url="http://www.gnome.org/gdp/doctable/">GNOME
      Documentation Status Table</ulink>. 
    </para>

  </chapter>

</book>