File: test-requirements.txt

package info (click to toggle)
glare 0.5.0-4
  • links: PTS, VCS
  • area: main
  • in suites: sid
  • size: 1,664 kB
  • sloc: python: 15,645; sh: 237; makefile: 59
file content (38 lines) | stat: -rw-r--r-- 1,146 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.

# Hacking already pins down pep8, pyflakes and flake8
hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0

# For translations processing
Babel!=2.4.0,>=2.3.4 # BSD

# Needed for testing
bandit>=1.1.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
fixtures>=3.0.0 # Apache-2.0/BSD
mox3>=0.20.0 # Apache-2.0
mock>=2.0.0 # BSD
sphinx>=1.6.2 # BSD
requests>=2.14.2 # Apache-2.0
testrepository>=0.0.18 # Apache-2.0/BSD
testresources>=2.0.0 # Apache-2.0/BSD
testscenarios>=0.4 # Apache-2.0/BSD
testtools>=1.4.0 # MIT
psutil>=3.2.2 # BSD
oslotest>=1.10.0 # Apache-2.0
os-testr>=1.0.0 # Apache-2.0

# Optional packages that should be installed when testing
PyMySQL>=0.7.6 # MIT License
psycopg2>=2.6.2 # LGPL/ZPL
pysendfile>=2.0.0 # MIT
qpid-python>=0.26;python_version=='2.7' # Apache-2.0
xattr>=0.9.2 # MIT
python-swiftclient>=3.2.0 # Apache-2.0

# Documentation
os-api-ref>=1.4.0 # Apache-2.0
oslosphinx>=4.7.0 # Apache-2.0
reno>=2.5.0 # Apache-2.0