File: changelog

package info (click to toggle)
glfw3 3.3-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 4,364 kB
  • sloc: ansic: 60,933; objc: 1,940; xml: 63; sh: 39; makefile: 24
file content (156 lines) | stat: -rw-r--r-- 5,055 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
glfw3 (3.3-1) unstable; urgency=medium

  * New upstream version.

  * d/control:
    - Bump debhelper compat to 12.
    - Add Suggests: libglfw3-doc to libglfw3-dev. (Closes: #890777)
    - Use secure Homepage URL.
    - Remove "Testsuite: autopkgtest" field.
    - Use new salsa git URLs.
    - Enable Rules-Requires-Root.
    - Bump standards to 4.3.0.
    - Remove "Priority: extra" from libglfw3-wayland.
    - Update build dependencies.
    - Add new runtime dependencies.
      libglfw3 and libglfw3-wayland now only depend on the libraries
      required by the default configuaration of glfw.
  * d/copyright:
    - Use secure URLs.
    - Various updates for 3.3.
  * d/not-installed: Add file to silence warnings.
  * d/patches: Refresh patches.
  * d/rules:
    - Remove --parallel flag from dh invocation.
    - Remove LIB_SUFFIX and GLFW_BUILD_ options.
    - Put documentation under libglfw-dev.
  * d/*.symbols: Add new symbols exported by 3.3.

 -- James Cowgill <jcowgill@debian.org>  Mon, 15 Jul 2019 11:52:48 +0100

glfw3 (3.2.1-1) unstable; urgency=medium

  * New upstream version.

 -- James Cowgill <jcowgill@debian.org>  Thu, 18 Aug 2016 16:46:41 +0000

glfw3 (3.2-4) unstable; urgency=medium

  * debian/control:
    - Drop build-dependency on libvulkan-dev.
    - Add version to extra-cmake-modules build-dependency.
  * debian/rules:
    - Only build wayland package on linux.

 -- James Cowgill <jcowgill@debian.org>  Sun, 26 Jun 2016 23:56:38 +0100

glfw3 (3.2-3) unstable; urgency=medium

  * Add 02_remove-pkgconfig-requires.patch to remove the Requires.private from
    glfw3.pc. Fixes the autopkgtest failures.

 -- James Cowgill <jcowgill@debian.org>  Fri, 24 Jun 2016 22:07:57 +0100

glfw3 (3.2-2) unstable; urgency=medium

  * Add libglfw3-wayland package using Wayland as the backend platform
    instead of X11. (Closes: #827125)

  * debian/control:
    - Demote X11 dependencies of libglfw3-dev to recommends.
    - Add manual dependency on GLX to libglfw3.
  * debian/rules:
    - Use -Wl,--as-needed to prevent libwayland-server dependency.
  * debian/*.symbols:
    - Add Build-Depends-Package line to symbols files.
  * debian/tests:
   - Run autopkgtests on X11 and Wayland backends.

 -- James Cowgill <jcowgill@debian.org>  Wed, 22 Jun 2016 11:56:23 +0100

glfw3 (3.2-1) unstable; urgency=medium

  * New upstream version.

  * debian/control:
    - Build-depend on libvulkan-dev.
    - Drop dependencies on libxi-dev.
  * debian/copyright:
    - Update for 3.2.
  * debian/libglfw3.symbols:
    - Add symbols added in 3.2.
  * debian/patches:
    - Drop cmake-config-fixes.patch -- applied upstream.
  * debian/tests:
    - Fix autopkgtests not working for non-patch versions of glfw.
    - Use the new glfw CMake import target in autopkgtest.

 -- James Cowgill <jcowgill@debian.org>  Fri, 03 Jun 2016 12:36:45 +0100

glfw3 (3.1.2-4) unstable; urgency=medium

  * debian/control:
   - Move doxygen to Build-Depends-Indep. (Closes: #825492)
   - Drop libglu-dev dependency from libglfw3-dev.
   - Switch to my debian.org email address.
   - Bump standards version (no changes).
  * debian/rules:
   - Enable all hardening options.

 -- James Cowgill <jcowgill@debian.org>  Fri, 27 May 2016 12:51:15 +0100

glfw3 (3.1.2-3) unstable; urgency=medium

  * debian/control:
    - Drop some obsolete build-dependencies.
    - Have libglfw3-dev depend on X11 libraries to fix the pkg-config file
      and the "build" autopkgtest.
    - Use secure Vcs-* URLs.
  * debian/tests:
    - Fix the "cmake" autopkgtest by depending on build-essential so that
      make is available.

 -- James Cowgill <james410@cowgill.org.uk>  Thu, 28 Jan 2016 14:45:22 +0000

glfw3 (3.1.2-2) unstable; urgency=medium

  * Fix and ship the cmake config files (Closes: #812853).
  * Added some autopkgtests to test if programs can be built using
    libglfw3-dev.

 -- James Cowgill <james410@cowgill.org.uk>  Wed, 27 Jan 2016 14:36:38 +0000

glfw3 (3.1.2-1) unstable; urgency=medium

  * New upstream version.

 -- James Cowgill <james410@cowgill.org.uk>  Mon, 12 Oct 2015 21:24:09 +0100

glfw3 (3.1.1-1) unstable; urgency=medium

  * New upstream version (Closes: #787320).

  * debian/control:
    - Drop 'Provides: libglfw-dev' from libglfw3-dev.
      - libglfw-dev refers only to the GLFW 2 API.
    - Add myself to the list of uploaders.
    - Bump standards version - no changes.
    - Use cgit Vcs-Browser URL.
    - Add new build dependencies for GLFW 3.1.
  * debian/copyright:
    - Updates for GLFW 3.1.
  * debian/patches:
    - Add patch to make the build reproducible (Closes: #790139).
  * debian/rules:
    - Enable parallel build.
    - Remove the override_dh_installdocs (it has no effect).
  * debian/watch:
    - Download upstream tarballs from the github repo instead of sourceforge.

 -- James Cowgill <james410@cowgill.org.uk>  Thu, 09 Jul 2015 10:20:25 +0100

glfw3 (3.0.4-1) unstable; urgency=low

  * Initial release (Closes: #736330)

 -- Roman Valov <roman.valov@gmail.com>  Tue, 11 Feb 2014 22:48:48 +0100