File: changelog

package info (click to toggle)
glm 0.9.9.3-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster
  • size: 7,508 kB
  • sloc: cpp: 34,524; sh: 24; makefile: 20
file content (271 lines) | stat: -rw-r--r-- 7,373 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
glm (0.9.9.3-2) unstable; urgency=medium

  * Unconditionally disable GLM_HAS_CONSTEXPR. (Closes: #920791)

 -- Guus Sliepen <guus@debian.org>  Thu, 31 Jan 2019 23:03:04 +0100

glm (0.9.9.3-1) unstable; urgency=medium

  * Updated debian/watch file.
  * New upstream version 0.9.9.3
  * Bump Standards-Version.
  * Build-Depend on debhelper-compat instead of using debian/compat.
  * Remove fix for GLM_FORCE_CTOR_INIT, it has been applied upstream.
  * Refresh patches.

 -- Guus Sliepen <guus@debian.org>  Mon, 28 Jan 2019 13:09:45 +0100

glm (0.9.9~a2-2) unstable; urgency=medium

  [ Andrew Caudwell ]
  * Backport upstream commit adding GLM_FORCE_CTOR_INIT. (Closes: #892861)

  [ Guus Sliepen ]
  * Remove unnecessary --parallel from debian/rules.
  * Update Vcs-* and Homepage links in debian/control.
  * Move glm.pc to /usr/share/pkgconfig/.

 -- Guus Sliepen <guus@debian.org>  Thu, 29 Mar 2018 15:08:45 +0200

glm (0.9.9~a2-1) unstable; urgency=medium

  * New upstream release.
    - Fixes FTBTS with GCC 7.3. Closes: #888550, #888661
  * Remove the fix-infiloop patch.
  * Rebuild the reference manual using Doxygen. Closes: #879517
  * Bump Standards-Version.
  * Add Rules-Requires-Root: no.

 -- Guus Sliepen <guus@debian.org>  Sun, 28 Jan 2018 18:37:59 +0100

glm (0.9.8.4-1) unstable; urgency=medium

  * New upstream release.
  * Make libglm-doc Multi-Arch: foreign.
  * Drop patches/fix-packing-test, a proper fix has been applied upstream.
  * Bump Standards-Version.

 -- Guus Sliepen <guus@debian.org>  Sat, 24 Jun 2017 17:27:12 +0200

glm (0.9.8.3-3) unstable; urgency=medium

  * Fix FTBFS on i386. Closes: 860701

 -- Guus Sliepen <guus@debian.org>  Wed, 19 Apr 2017 16:39:23 +0200

glm (0.9.8.3-2) unstable; urgency=medium

  * Team upload

  [ Ghislain Antony Vaillant ]
  * Clear old patch queue, no longer needed
  * Fix CMake detection on all architectures
    - New patch Fix-CMake-package-version-file.patch (Closes: #850277, #850243)

 -- Ghislain Antony Vaillant <ghisvail@gmail.com>  Wed, 11 Jan 2017 23:58:59 +0000

glm (0.9.8.3-1) unstable; urgency=medium

  * New upstream version 0.9.8.3
  * Bump debian/compat.

 -- Guus Sliepen <guus@debian.org>  Wed, 07 Dec 2016 16:27:40 +0100

glm (0.9.8.1-1) unstable; urgency=medium

  * New upstream version 0.9.8.1

 -- Guus Sliepen <guus@debian.org>  Thu, 06 Oct 2016 15:19:26 +0200

glm (0.9.8.0-1) unstable; urgency=medium

  [ Ghislain Antony Vaillant ]
  * Add gbp configuration file.
  * Run cme fix on d/control and d/copyright.
  * Move maintenance over to the Debian Science Team.

  [ Guus Sliepen ]
  * New upstream version 0.9.8.0

 -- Guus Sliepen <guus@debian.org>  Fri, 23 Sep 2016 14:16:07 +0200

glm (0.9.7.6-1) unstable; urgency=medium

  [ Guus Sliepen ]
  * New upstream release.

  [ Ghislain Antony Vaillant ]
  * Fix CMake package installation. Closes: #827799
  * Enable testing depending on nocheck.
  * Add packaging testsuite.

 -- Guus Sliepen <guus@debian.org>  Wed, 24 Aug 2016 22:07:20 +0200

glm (0.9.7.5-1) unstable; urgency=medium

  * New upstream release.
  * Add a glm.pc file. Closes: #737088
  * Bump Standards-Version.

 -- Guus Sliepen <guus@debian.org>  Mon, 30 May 2016 12:43:03 +0200

glm (0.9.7.4-1) unstable; urgency=medium

  * New upstream release.
  * Install .cmake files in /usr/lib/cmake/glm. Closes: #812855

 -- Guus Sliepen <guus@debian.org>  Wed, 06 Apr 2016 15:58:47 +0200

glm (0.9.7.3-1) unstable; urgency=medium

  * New upstream release.
  * Update debian/watch to use xz compression.
  * Bump Standards-Version.

 -- Guus Sliepen <guus@debian.org>  Wed, 24 Feb 2016 16:39:20 +0100

glm (0.9.7.2-1) unstable; urgency=medium

  * New upstream release.

 -- Guus Sliepen <guus@debian.org>  Sun, 24 Jan 2016 22:49:41 +0100

glm (0.9.7.1-1) unstable; urgency=medium

  * New upstream release.

 -- Guus Sliepen <guus@debian.org>  Sun, 20 Sep 2015 14:38:03 +0200

glm (0.9.7.0-1) unstable; urgency=medium

  * New upstream release.
  * Update debian/watch file to look for releases on GitHub.
  * Use a symlink to the libjs-jquery package for jquery.js.
  * Update debian/copyright.
  * Enable dh --parallel.

 -- Guus Sliepen <guus@debian.org>  Wed, 02 Sep 2015 16:16:54 +0200

glm (0.9.6.3-1) unstable; urgency=medium

  * New upstream release. Closes: #766154

 -- Guus Sliepen <guus@debian.org>  Mon, 20 Apr 2015 13:19:12 +0200

glm (0.9.5.4-1) unstable; urgency=medium

  * New upstream release.
  * Bump Standards-Version.

 -- Guus Sliepen <guus@debian.org>  Mon, 06 Oct 2014 14:30:41 +0200

glm (0.9.5.3-1) unstable; urgency=medium

  * New upstream release.

 -- Guus Sliepen <guus@debian.org>  Fri, 16 May 2014 12:21:49 +0200

glm (0.9.5.2-1) unstable; urgency=medium

  * New upstream release.

 -- Guus Sliepen <guus@debian.org>  Tue, 04 Mar 2014 14:01:01 +0100

glm (0.9.5.1-1) unstable; urgency=medium

  * New upstream release.
    - Fixes attempt to access private class members. Closes: #736264
  * Apply commit d7862e4 from upstream to prevent the tests from trying to use
    SSE2 instructions on platforms that don't support them. Closes: #735270

 -- Guus Sliepen <guus@debian.org>  Wed, 05 Feb 2014 16:47:42 +0100

glm (0.9.5.0-1) unstable; urgency=medium

  * New upstream release.
  * Bump Standards-Version.

 -- Guus Sliepen <guus@debian.org>  Tue, 07 Jan 2014 14:49:22 +0100

glm (0.9.4.6-2) unstable; urgency=low

  [ Steve Langasek ]
  * Add Multi-Arch: foreign header to facilitate cross-compilation.

 -- Guus Sliepen <guus@debian.org>  Wed, 09 Oct 2013 23:07:07 +0200

glm (0.9.4.6-1) unstable; urgency=low

  * New upstream release.

 -- Guus Sliepen <guus@debian.org>  Mon, 30 Sep 2013 00:00:39 +0200

glm (0.9.4.5-1) unstable; urgency=low

  * New upstream release.

 -- Guus Sliepen <guus@debian.org>  Sun, 18 Aug 2013 16:18:00 +0200

glm (0.9.4.4-1) unstable; urgency=low

  * New upstream release.
  * Run build-time tests. Closes: #707536

 -- Guus Sliepen <guus@debian.org>  Thu, 18 Jul 2013 12:46:46 +0200

glm (0.9.4.3-1) unstable; urgency=low

  * New upstream release.

 -- Guus Sliepen <guus@debian.org>  Sun, 05 May 2013 10:45:59 +0200

glm (0.9.3.3+dfsg-0.1) unstable; urgency=low

  * Non-maintainer upload.
  * Repack without non DFSG-free material. Closes: #685232

 -- David Prévot <taffit@debian.org>  Thu, 30 Aug 2012 23:34:20 -0400

glm (0.9.3.3-1) unstable; urgency=low

  * New upstream release.

 -- Guus Sliepen <guus@debian.org>  Mon, 25 Jun 2012 22:55:53 +0200

glm (0.9.3.2-1) unstable; urgency=low

  * New upstream release.

 -- Guus Sliepen <guus@debian.org>  Wed, 21 Mar 2012 00:14:12 +0100

glm (0.9.3.1-1) unstable; urgency=low

  * New upstream release.

 -- Guus Sliepen <guus@debian.org>  Mon, 30 Jan 2012 12:31:46 +0100

glm (0.9.2.7-1) unstable; urgency=low

  * New upstream release.
  * Don't install jquery.js, it is not used anyway.

 -- Guus Sliepen <guus@debian.org>  Sat, 12 Nov 2011 16:09:24 +0100

glm (0.9.2.6-1) unstable; urgency=low

  * New upstream release.

 -- Guus Sliepen <guus@debian.org>  Tue, 04 Oct 2011 14:10:36 +0200

glm (0.9.2.0-2) unstable; urgency=low

  * Fix grammar in the package description.
  * Set section of libglm-doc to doc.

 -- Guus Sliepen <guus@debian.org>  Tue, 17 May 2011 10:21:57 +0200

glm (0.9.2.0-1) unstable; urgency=low

  * Initial release.

 -- Guus Sliepen <guus@debian.org>  Mon, 16 May 2011 14:55:26 +0200