1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133
|
include /usr/share/quilt/quilt.make
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
build-arch: build
build-indep: build
build: build-stamp
build-stamp: patch
dh_testdir
scons INSTALLDIR=/usr/share/games/glob2 BINDIR=/usr/games/ --portaudio=true
touch build-stamp
clean: unpatch
dh_testdir
dh_testroot
rm -f build-stamp
dh_clean
scons --portaudio=true -c
rm -rf .sconf_temp/ .sconsign.dblite options_cache.py config.log config.h scons/*.pyc
rm -f debian/patches/tutorial-part4.map.bspatch
install: build
dh_testdir
dh_testroot
dh_prep
dh_installdirs
mkdir -p $(CURDIR)/debian/tmp/usr/share/games/glob2 $(CURDIR)/debian/tmp/usr/games
cp -a campaigns/ data/ maps/ scripts/ $(CURDIR)/debian/tmp/usr/share/games/glob2
uudecode -o debian/patches/tutorial-part4.map.bspatch debian/patches/tutorial-part4.map.uuencode
bspatch campaigns/tutorial-part4.map \
`find $(CURDIR)/debian/tmp -name "*tutorial-part4.map"` \
debian/patches/tutorial-part4.map.bspatch
cp -a src/glob2 $(CURDIR)/debian/tmp/usr/games/
find $(CURDIR)/debian/tmp/usr/share/games/glob2 -type f -exec chmod 664 {} \;
find $(CURDIR)/debian/tmp/usr/share/games/glob2 -name SConscript -o -name \*.py -o -name \*.sh -o -name \*.perl | xargs rm
mkdir -p debian/tmp/usr/share/pixmaps
cp debian/glob2-32x32.xpm debian/tmp/usr/share/pixmaps/.
binary-indep: build install
dh_testdir -i
dh_testroot -i
dh_installchangelogs ChangeLog -i
dh_installdocs -i
dh_install -i --sourcedir=debian/tmp --list-missing -Xglob2.desktop
dh_link -i
dh_strip -i
dh_compress -i
dh_fixperms -i
dh_installdeb -i
dh_gencontrol -i
dh_md5sums -i
dh_builddeb -i
binary-arch: build install
dh_testdir -a
dh_testroot -a
dh_installchangelogs -a ChangeLog
dh_installdocs -a
dh_install -a --sourcedir=debian/tmp
dh_installmenu -a
dh_installman -a debian/glob2.6
dh_link -a
dh_strip -a
dh_compress -a
dh_fixperms -a
dh_installdeb -a
dh_shlibdeps -a
dh_gencontrol -a
dh_md5sums -a
dh_builddeb -a
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install build build-arch build-indep
|