1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103
|
-include /usr/share/dpkg/buildflags.mk
name = globus-gridftp-server-control
_name = globus_gridftp_server_control
INSTALLDIR = $(CURDIR)/debian/tmp
_prefix = /usr
_bindir = $(_prefix)/bin
_sbindir = $(_prefix)/sbin
_includedir = $(_prefix)/include
_libdir = $(_prefix)/lib
_datadir = $(_prefix)/share
_mandir = $(_datadir)/man
_docdir = $(_datadir)/doc/lib$(name)-dev
configure: configure-stamp
configure-stamp:
dh_testdir
dh_autoreconf
CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" \
FFLAGS="$(FFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
LDFLAGS="$(LDFLAGS) -Wl,--as-needed -Wl,-z,defs" \
dh_auto_configure -- \
--disable-static \
--includedir=$(_includedir)/globus \
--libexecdir=$(_datadir)/globus \
--docdir=$(_docdir)
sed 's!CC \(.*-shared\) !CC \\\$${wl}--as-needed \1 !' -i libtool
touch $@
build: build-arch build-indep
build-arch: build-stamp
build-indep:
build-stamp: configure-stamp
dh_testdir
$(MAKE)
touch $@
clean:
dh_testdir
dh_testroot
if [ -r Makefile ] ; then $(MAKE) distclean ; fi
dh_autoreconf_clean
rm -f build-stamp configure-stamp
dh_clean
install: build-stamp
dh_testdir
dh_testroot
dh_prep
$(MAKE) install DESTDIR=$(INSTALLDIR)
rm $(INSTALLDIR)$(_libdir)/*/*.la
rm $(INSTALLDIR)$(_docdir)/GLOBUS_LICENSE
binary: binary-arch binary-indep
binary-arch: install
dh_testdir
dh_testroot
dh_installdocs debian/README
dh_installchangelogs
dh_install
dh_missing --fail-missing
dh_installman
dh_link
dh_strip --dbgsym-migration='lib$(name)-dbg (<< 5.0-3~), $(name)-dbg (<< 2.10)'
dh_compress
dh_fixperms
dh_perl
dh_makeshlibs
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary-indep:
.PHONY: binary binary-arch binary-indep build build-arch build-indep clean configure install
|