1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57
|
From: Matthias Geiger <werdahias@debian.org>
Date: Fri, 5 Jul 2024 19:10:21 +0200
Subject: Skip cargo tests as they are broken
Forwarded: not-needed
loaders/meson.build | 38 --------------------------------------
1 file changed, 38 deletions(-)
@@ -161,44 +161,4 @@
env += {'GLYCIN_DATA_DIR': destdir + datadir}
endif
- test(
- 'cargo-test',
- cargo_bin,
- args: [
- 'test',
- '-p', 'tests',
- test_args,
- # Not using a separate target dir causes rebuilds for the loaders
- '--target-dir', cargo_target_dir / 'tests',
- cargo_options,
- '--',
- '--test-threads=1',
- '--nocapture',
- ],
- env: env,
- is_parallel: false,
- timeout: 1800,
- )
-
- if get_option('tokio_tests')
- test(
- 'cargo-test-tokio',
- cargo_bin,
- args: [
- 'test',
- '-p', 'tests',
- '--no-default-features',
- '--features', 'tokio',
- # Not using a separate target dir causes rebuilds for the loaders
- '--target-dir', cargo_target_dir / 'tests',
- cargo_options,
- '--',
- '--test-threads=1',
- '--nocapture',
- ],
- env: env,
- is_parallel: false,
- timeout: 1800,
- )
- endif
endif
\ No newline at end of file
|