1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export CONFIG_SHELL = /bin/sh
ifeq (,$(wildcard /usr/share/perl5/Debian/Debhelper/Sequence/cli.pm))
WITH_CLI =
CONFIGURE_MONO_FLAGS = --enable-mono=no
else
WITH_CLI = ,cli
CONFIGURE_MONO_FLAGS = CSC=/usr/bin/mono-csc
endif
override_dh_auto_configure:
dh_auto_configure -- \
$(shell dpkg-buildflags --export=configure) \
--enable-vala \
--enable-gtk-doc \
--disable-rpath \
--enable-largefile \
--enable-smime \
--enable-introspection \
$(CONFIGURE_MONO_FLAGS)
override_dh_clideps:
if ! grep -q . debian/*/DEBIAN/shlibs; then echo libgmime-2.6 0 libgmime-2.6-0 > debian/shlibs.local; fi
dh_clideps
rm -f debian/shlibs.local
%:
dh $@ --with=autoreconf,gir$(WITH_CLI)
|