1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32
|
DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
export DEB_BUILD_MAINT_OPTIONS=hardening=+all
CFLAGS := $(subst -O2,-O3,$(CFLAGS))
default:
@uscan --no-conf --dehs --report || true
%:
dh $@ --builddirectory=_build
override_dh_auto_configure:
dh_auto_configure -- --enable-shared --enable-maintainer-mode
override_dh_auto_build-indep:
true
override_dh_auto_test-indep:
true
override_dh_auto_install-indep:
$(MAKE) -C _build install-data-am DESTDIR=$(CURDIR)/debian/tmp
override_dh_compress-indep:
dh_compress -Xexamples
|