1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107
|
.NOTPARALLEL:
CFLAGS = -Wall -g -fgnu89-inline
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS += -O0
else
CFLAGS += -O2
endif
clean:
dh_testdir
dh_testroot
rm -f build-stamp configure-stamp
[ ! -f Makefile ] || $(MAKE) distclean
rm -f config/config.guess config/config.sub
dh_autoreconf_clean
dh_clean
configure: configure-stamp
configure-stamp:
dh_testdir
dh_autoreconf
./configure --prefix=/usr --mandir=/usr/share/man \
--with-x --enable-nls --enable-security \
--enable-smsd --enable-libpcsclite --enable-bluetooth \
--enable-irda --enable-libusb --enable-libical \
--disable-rpath \
CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
touch configure-stamp
build-arch: build
build-indep: build
build: configure-stamp build-stamp
build-stamp:
dh_testdir
$(MAKE)
touch build-stamp
install: build
dh_testdir
dh_testroot
dh_prep
$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp/
for file in $(CURDIR)/debian/tmp/usr/lib/*.la; do \
sed -i "/dependency_libs/ s/'.*'/''/" $$file ; \
done
install -m 644 -D $(CURDIR)/debian/gnokiirc \
$(CURDIR)/debian/tmp/etc/xdg/gnokii/config
binary-indep: build install
dh_testdir -i
dh_testroot -i
dh_link -i
dh_installdocs -p gnokii-common
dh_installexamples -i
dh_installchangelogs -p gnokii-common ChangeLog
dh_install -i --sourcedir=$(CURDIR)/debian/tmp
dh_compress -i
dh_fixperms -i
dh_installdeb -i
dh_gencontrol -i
dh_md5sums -i
dh_builddeb -i
binary-arch: build install
dh_testdir -a
dh_testroot -a
dh_link -a
dh_installdocs -p gnokii-smsd -p gnokii-smsd-mysql -p gnokii-smsd-pgsql
dh_installexamples -a
dh_installmenu -a
dh_installman -a
dh_installchangelogs -p gnokii-smsd -p gnokii-smsd-mysql -p gnokii-smsd-pgsql smsd/ChangeLog
dh_install -a --sourcedir=$(CURDIR)/debian/tmp
dh_strip -a
dh_compress -a
dh_fixperms -a
dh_makeshlibs -a
dh_installdeb -a
dh_shlibdeps -a -l$(CURDIR)/debian/tmp/usr/lib
dh_gencontrol -a
dh_md5sums -a
dh_builddeb -a
binary: binary-indep binary-arch
.PHONY: build build-arch build-indep clean binary-indep binary-arch binary install configure
|