File: postrm

package info (click to toggle)
gnumed-server 22.15-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye
  • size: 46,556 kB
  • sloc: sql: 1,217,005; python: 15,469; sh: 1,553; makefile: 20
file content (52 lines) | stat: -rw-r--r-- 1,290 bytes parent folder | download | duplicates (6)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
#!/bin/sh
# prerm script for gnumed-server
#
# see: dh_installdeb(1)

set -e

# summary of how this script can be called:
#        * <prerm> `remove'
#        * <old-prerm> `upgrade' <new-version>
#        * <new-prerm> `failed-upgrade' <old-version>
#        * <conflictor's-prerm> `remove' `in-favour' <package> <new-version>
#        * <deconfigured's-prerm> `deconfigure' `in-favour'
#          <package-being-installed> <version> `removing'
#          <conflicting-package> <version>
# for details, see http://www.debian.org/doc/debian-policy/ or
# the debian-policy package

GMSERVERDIR=/var/lib/gnumed
GMLOGDIR=/var/log/gnumed

case "$1" in
    purge)
        rm -rf $GMSERVERDIR
        rm -rf $GMLOGDIR
        # Delete possibly existing links to /etc/gnumed/@gm-logins
        if [ -d /etc/postgresql ] ; then
          find /etc/postgresql -type l -name @gm-logins -exec rm -f \{\} \;
        fi
    ;;
    remove|upgrade|deconfigure)
	if [ -d $GMSERVERDIR ] ; then
	    find $GMSERVERDIR -name "*.pyc" | xargs rm -f
	fi
    ;;
    failed-upgrade)
    ;;

    *)
        echo "postrm called with unknown argument \`$1'" >&2
        exit 1
    ;;
esac

# dh_installdeb will replace this with shell code automatically
# generated by other debhelper scripts.

#DEBHELPER#

exit 0