File: changelog

package info (click to toggle)
gnuserv 3.12.8-7
  • links: PTS
  • area: main
  • in suites: bookworm, bullseye, buster, sid
  • size: 772 kB
  • sloc: ansic: 5,138; lisp: 966; sh: 269; makefile: 240
file content (285 lines) | stat: -rw-r--r-- 9,407 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
gnuserv (3.12.8-7) unstable; urgency=low

  * lifted standards version, updated debhelper compat level
  * removed watch file, upstream website has vanished

 -- Alexander Zangerl <az@debian.org>  Sun, 14 Jan 2018 13:34:32 +1000

gnuserv (3.12.8-6) unstable; urgency=low

  * updated dependencies, no longer mentions emacs23 specifically
  (closes: #754037)

 -- Alexander Zangerl <az@debian.org>  Tue, 08 Jul 2014 18:19:06 +1000

gnuserv (3.12.8-5) unstable; urgency=low

  * updated manpage for dtemacs (closes: #280368)

 -- Alexander Zangerl <az@debian.org>  Mon, 16 Sep 2013 22:34:32 +1000

gnuserv (3.12.8-4) unstable; urgency=low

  * changed to 3.0 quilt source format
  * lifted standards version, updated watch file
  * enabled hardening build flags

 -- Alexander Zangerl <az@debian.org>  Sun, 15 Sep 2013 23:47:58 +1000

gnuserv (3.12.8-3) unstable; urgency=low

  * under new management: reintroducing this package
  * lifted standards version

 -- Alexander Zangerl <az@debian.org>  Wed, 16 May 2012 10:56:32 +1000

gnuserv (3.12.8-2) unstable; urgency=low

  * add documentation about loading gnuserv-compat (Closes: 542476) 
  * upgrade policy to 3.9.1 (no changes needed)
  * change depends to emacs | emacs23

 -- Mike O'Connor <stew@debian.org>  Tue, 10 Aug 2010 20:19:20 -0400

gnuserv (3.12.8-1) unstable; urgency=low

  * new upstream version
  * added watch file

 -- Mike O'Connor <stew@debian.org>  Wed, 14 Nov 2007 06:27:27 -0500

gnuserv (3.12.7-5) unstable; urgency=low

  * Adding support for emacs22 (Thanks Junichi Uekawa) (Closes: 432854) 

 -- Mike O'Connor <stew@vireo.org>  Mon, 23 Jul 2007 23:47:37 -0400

gnuserv (3.12.7-4) unstable; urgency=low

  * adding support for -snapshot
  * added dtemacs as an editor alternative (Closes: #397049)
  * fix patches to unapply cleanly (Closes: #424355)
  * fix typo in gnuclient(1) manpage (Closes: #400133)

 -- Mike O'Connor <stew@vireo.org>  Sat, 19 May 2007 14:02:22 -0400

gnuserv (3.12.7-3) unstable; urgency=low

  * New Maintainer (Closes: 393257)
  * Change packaging to dpatch
  * Added patch for ./configure from NMU that fixes missing X includes
    (Thanks: Stelios Bounanos) (Closes: 367983)
  * Remove woody/potato specific code in .postinst
  * Remove GFDL text from copyright, as no works in the package are
    distributed under that license
  * Updated Standards-Version to 3.7.2
  * Added a README.Debian documenting how to start gnuserv (Closes: 323567)
  * Altered gnuserv(1) manpage to not be XEmacs specific (Closes: 379139, 368386)
  * Added patch to remove strerror (Thanks Andreas Jochens) (Closes: 363277)

 -- Mike O'Connor <stew@vireo.org>  Wed, 18 Oct 2006 01:43:49 -0400

gnuserv (3.12.7-2.3) unstable; urgency=low

  * Orphan package

 -- Debian QA Group <packages@qa.debian.org>  Sun, 15 Oct 2006 21:36:44 +0200

gnuserv (3.12.7-2.2) unstable; urgency=low

  * NMU
  * Rebuilt with Unix Domain sockets, Internet Domain sockets or System V IPC
    (Closes: #367983)

 -- Julien Danjou <acid@debian.org>  Sun, 21 May 2006 22:03:29 +0200

gnuserv (3.12.7-2.1) unstable; urgency=low

  * NMU
  * Remove declaration of strerror from sysfile.h, fixing FTBFS
    (Closes: #363277)

 -- Julien Danjou <acid@debian.org>  Wed, 17 May 2006 11:24:02 +0200

gnuserv (3.12.7-2) unstable; urgency=low

  * Use debian-pkg-add-load-path-item to add a path to emacs load path
    (closes: #328715)
  * Fix man page (closes: #331152)
  * Add gnuserv.desktop file (closes: #304062)
  * Optionally depend on emacsen, thus allowing using gnuserv with other
    emacsen, like emacs-snapshot (closes: #352872)
  
 -- Benjamin Drieu <benj@debian.org>  Mon, 17 Apr 2006 13:52:46 +0200

gnuserv (3.12.7-1.2) unstable; urgency=medium

  * NMU.
  * Add a build dependency on libxt-dev to placate configure.
    Closes: #349554.

 -- Matej Vela <vela@debian.org>  Mon, 20 Feb 2006 09:42:19 +0100

gnuserv (3.12.7-1.1) unstable; urgency=low

  * Non-maintainer upload.
  * Replace build-dependency on xlibs-dev with an explicit build-dependency
    on each required package. (Closes: #346753)

 -- Steinar H. Gunderson <sesse@debian.org>  Mon, 23 Jan 2006 00:47:19 +0100

gnuserv (3.12.7-1) unstable; urgency=low

  * New upstream release (closes: #279005)
  * Explicitely set gnuserv-program (closes: #291123)

 -- Benjamin Drieu <benj@debian.org>  Thu, 10 Mar 2005 13:43:08 +0100

gnuserv (3.12.6-1.1) unstable; urgency=low

  * NMU
  * Added complete GFDL text to debian/copyright and correct license
    location to debian/dtemacs.1 (closes: #292228)
  * Corrected Standards-Version from 3.6.10 to 3.6.1.

 -- Paul Brossier <piem@altern.org>  Fri,  4 Feb 2005 22:36:48 +0000
 
gnuserv (3.12.6-1) unstable; urgency=low

  * New upstream version (closes: #209126)
  * Remove dependencies on emacs20 (closes: #232737, #232761)
  * Move conffile to /etc/emacs21.  Removing this package but not purging
    it still makes emacs21 croak, but no more other flavours (hopefully
    closes: #207245)

 -- Benjamin Drieu <benj@debian.org>  Mon, 16 Feb 2004 12:27:42 +0100

gnuserv (3.12.4-5) unstable; urgency=low

  * Remote evaluation now work without DISPLAY being set (Closes: #149938)
  * install.log is now universally readable (Closes: #167717)

 -- Benjamin Drieu <benj@debian.org>  Wed, 12 Feb 2003 16:45:40 +0100

gnuserv (3.12.4-4) unstable; urgency=low

  * Quiet down postinst.  (Closes: #143341)
  * Install dtemacs.  (Closes: #144039)

 -- Benjamin Drieu <benj@debian.org>  Tue, 30 Apr 2002 16:41:21 +0200

gnuserv (3.12.4-3) unstable; urgency=low

  * Add some hints about using xauth in gnuserv man page.  (Closes: #99195)

 -- Benjamin Drieu <benj@debian.org>  Wed,  3 Apr 2002 17:26:08 +0200

gnuserv (3.12.4-2) unstable; urgency=low

  * Suppress gnuclient -nw, that does not work with GNU Emacs.  As
    debian's gnuserv/gnuclient is supposed to work only with GNU Emacs
    since xemacs provides its own gnuclient.xemacs21, I remove any
    advertisement to that feature.  (Closes: #119927, #116921,
    #133266, #134972)

  * Buffer overrun fix (Closes: #137912)

  * Closes: #132134.

 -- Benjamin Drieu <benj@debian.org>  Fri, 15 Mar 2002 20:58:10 +0100

gnuserv (3.12.4-1) unstable; urgency=low

  * New maintainer. (Closes: #120051)
  * New upstream version. (Closes: #99915, #92642)

 -- Benjamin Drieu <benj@debian.org>  Thu, 21 Feb 2002 00:21:47 +0100

gnuserv (3.12.3-3.1) unstable; urgency=low

  * Non Maintainer Upload.
  * mark /etc/emacs/site-start.d/50gnuserv.el as a conffile
    (closes: #132134)

 -- David Kimdon <dwhedon@debian.org>  Thu,  7 Feb 2002 23:10:16 -0800

gnuserv (3.12.3-3) unstable; urgency=medium

  * Urgency medium in hopes of preventing woody from releasing with
    a broken gnuserv package which claims to require emacs20 even
    though emacs21 works just fine.  This silliness would not be
    necessary had i been able to say emacs >= 20...
  * Update to Standards-Version 3.5.6 (no actual changes necessary).
  * debian/control: Use emacs21 | emacs20 in Depends and Build-Depends.
    (Closes: #118583)
  * debian/postinst: Clean up garbage left behind by potato version.
    (Closes: #99191)
  * Verify that symlinks to the appropriate man pages are
    installed. (Closes: #99534)

 -- Eric Gillespie, Jr. <epg@debian.org>  Wed,  7 Nov 2001 20:56:34 +0000

gnuserv (3.12.3-2) unstable; urgency=low

  * Add Build-Depends: emacs20. (Closes: #90213)

 -- Eric Gillespie, Jr. <epg@debian.org>  Mon, 19 Mar 2001 09:53:47 -0500

gnuserv (3.12.3-1) unstable; urgency=low

  * New maintainer. (Closes: #89717)
  * New upstream version. (Closes: #84627, #85600, #88961, #67831, #84802)
  * Repackage from scratch using debhelper. The upstream package has
    changed substantially, and the Debian package was out-of-date with
    regard to policy, so i figured this would be for the best.
  * Now uses alternatives for the programs and manpages.
    (Closes: #48445, #37658)
  * Now uses dh_installemacsen and follows emacsen policy.
    (Closes: #62093, #67406)
  * Add Build-Depends. (Closes: #89135)

 -- Eric Gillespie, Jr. <epg@debian.org>  Sun, 18 Mar 2001 00:49:54 -0500

gnuserv (2.1alpha-5.1.1) unstable; urgency=high

  * Non-Maintainer Upload by Security Team
  * Applied patch from Klaus Frank that fixes weak access control which
    could lead random remote users execute commands under the local user
    id bypassing access control.

 -- Martin Schulze <joey@debian.org>  Thu,  8 Mar 2001 22:25:16 +0100

gnuserv (2.1alpha-5) unstable; urgency=low

  * gnuserv.el is byte compiled now.
  * don't compile for xemacs. Closes Bug#33012 and Bug#28175.

 -- Frederic Lepied <Lepied@debian.org>  Tue, 16 Feb 1999 20:41:12 +0100

gnuserv (2.1alpha-4) unstable; urgency=low

  * added autoloads in /etc/emacs/site_start.d

 -- Frederic Lepied <Lepied@debian.org>  Thu, 19 Mar 1998 06:16:39 +0100

gnuserv (2.1alpha-3) unstable; urgency=low

  * depends on emacsen.

 -- Frederic Lepied <Lepied@debian.org>  Sun, 15 Mar 1998 08:09:17 +0100

gnuserv (2.1alpha-2) unstable; urgency=low

  * Uncompress the copyright file (Fixes Bug#14399).
  * README.debian:   corrected bad spelling and   changed to a more secure
    xauth command (Fixes Bug#13943).

 -- Frederic Lepied <Lepied@debian.org>  Wed, 28 Jan 1998 05:33:46 +0100

gnuserv (2.1alpha-1) unstable; urgency=low

  * Initial Release.

 -- Frederic Lepied <Lepied@debian.org>  Mon, 13 Oct 1997 22:22:05 +0200