1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59
|
include /usr/share/dpkg/pkg-info.mk
export FORCE_SOURCE_DATE = 1
CFLAGS := -g -O2
CXXFLAGS := $(CFLAGS)
OBJCFLAGS :=
CPPFLAGS :=
LDFLAGS :=
export DESTDIR=$(CURDIR)/debian/tmp
%:
dh $@ \
--builddirectory=build-gnustep-make
override_dh_auto_configure:
dh_auto_configure -- \
--with-layout=debian SHELLPROG=/bin/bash
override_dh_auto_build-indep:
$(MAKE) -C build-gnustep-make
mkdir $(CURDIR)/Documentation/build-gnustep-make-doc; \
cd $(CURDIR)/Documentation/build-gnustep-make-doc; \
../../configure --prefix="$(CURDIR)/Documentation/temp-installation" \
--with-layout=debian; \
$(MAKE); \
$(MAKE) install
$(MAKE) -C Documentation \
messages=yes \
GNUSTEP_MAKEFILES=$(CURDIR)/Documentation/temp-installation/share/GNUstep/Makefiles \
PATH="$$PATH:$(CURDIR)/Documentation/temp-installation/bin"
override_dh_auto_install-indep:
$(MAKE) -C build-gnustep-make install \
DESTDIR=$(CURDIR)/debian/tmp
test -d Documentation/temp-installation && $(MAKE) -C Documentation install \
messages=yes \
GNUSTEP_MAKEFILES=$(CURDIR)/Documentation/temp-installation/share/GNUstep/Makefiles \
GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
PATH="$$PATH:$(CURDIR)/Documentation/temp-installation/bin" \
DESTDIR=""
|