File: changelog

package info (click to toggle)
golang-fsnotify 1.4.9-2
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye, bullseye-proposed-updates, sid
  • size: 260 kB
  • sloc: makefile: 2
file content (135 lines) | stat: -rw-r--r-- 4,533 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
golang-fsnotify (1.4.9-2) unstable; urgency=medium

  * Team upload.
  * Update maintainer address to team+pkg-go@tracker.debian.org

 -- Shengjing Zhu <zhsj@debian.org>  Sun, 19 Apr 2020 20:36:17 +0800

golang-fsnotify (1.4.9-1) unstable; urgency=medium

  * Team upload.

  [ Dmitry Smirnov ]
  * Standards-Version: 4.4.1

  [ Debian Janitor ]
  * Bump debhelper from old 11 to 12.
  * Set debhelper-compat version in Build-Depends.
  * Set upstream metadata fields:
    Bug-Database, Bug-Submit, Repository, Repository-Browse.

  [ Shengjing Zhu ]
  * New upstream version 1.4.9
    https://github.com/fsnotify/fsnotify/pull/265 this patch in new version
    may fix TestInotifyOverflow (Closes: #929717)
  * Update Standards-Version to 4.5.0 (no changes)
  * Add Rules-Requires-Root

 -- Shengjing Zhu <zhsj@debian.org>  Sun, 19 Apr 2020 18:41:48 +0800

golang-fsnotify (1.4.7-2) unstable; urgency=medium

  [ Alexandre Viau ]
  * Point Vcs-* urls to salsa.debian.org.

  [ Martín Ferrari ]
  * Add new possible import path, as upstream can't make up their mind :/
  * Automated cme fixes.
  * Reconfigure repo with current std.

 -- Martín Ferrari <tincho@debian.org>  Sun, 10 Jun 2018 17:59:24 +0000

golang-fsnotify (1.4.7-1) unstable; urgency=medium

  [ Paul Tagliamonte ]
  * Remove Built-Using from arch:all -dev package

  [ Anthony Fok ]
  * New upstream version 1.4.7
  * Bump Standards-Version to 4.1.3:
    Use https form of the copyright-format URL in debian/copyright,
    and change priority from extra to optional.
  * Use debhelper (>= 11).
  * Add myself to the list of Uploaders.
  * Apply "cme fix dpkg" fixes to debian/control.
  * Remove all old transitional packages, namely, golang-fsnotify-dev
    and golang-github-go-fsnotify-fsnotify-dev.

 -- Anthony Fok <foka@debian.org>  Fri, 02 Mar 2018 07:19:15 -0700

golang-fsnotify (1.4.2-1) unstable; urgency=medium

  * New upstream release.
  * Re-enable previously flaky test.
  * debian/control: Replace golang-go with golang-any in Build-Depends.

 -- Martín Ferrari <tincho@debian.org>  Tue, 01 Nov 2016 01:38:48 +0000

golang-fsnotify (1.3.0-4) unstable; urgency=medium

  * Disable flaky test. Closes: 835057.

 -- Martín Ferrari <tincho@debian.org>  Tue, 23 Aug 2016 20:05:07 +0000

golang-fsnotify (1.3.0-3) unstable; urgency=medium

  * Update versioned dependency on x/sys, as the new code fixes problems in
    PPC64*.

 -- Martín Ferrari <tincho@debian.org>  Sat, 30 Apr 2016 21:24:04 +0000

golang-fsnotify (1.3.0-2) unstable; urgency=high

  * Add golang-golang-x-sys-dev to the list of dependencies. Closes: #822395.

 -- Martín Ferrari <tincho@debian.org>  Tue, 26 Apr 2016 18:35:10 +0000

golang-fsnotify (1.3.0-1) unstable; urgency=medium

  [ Martín Ferrari ]
  * New upstream release, which fixes issues in arm64.
  * Added dependency on latest golang-golang-x-sys-dev.
  * Add myself to the list of Uploaders
  * Updated Standards-Version with no changes.
  * Updated Import-Path to reflect namespace change (now it is
    fsnotify/fsnotify). Added compatibility symlink.

  [ Anthony Fok ]
  * Bump Standards-Version to 3.9.8 with no change.
  * Update Vcs-* fields to use secure HTTPS URIs.
  * Revert "Build-Depends on gccgo where golang-go is not available".
    See https://github.com/Debian/dh-make-golang/pull/36 for discussions.
  * Transition to golang-github-fsnotify-fsnotify-dev.  Upstream has decided
    to move away from gopkg.in and rename organization "go-fsnotify" to
    "fsnotify".  Hence, we rename the Debian package name accordingly.
    See https://github.com/fsnotify/fsnotify/issues/108 for details.

 -- Anthony Fok <foka@debian.org>  Fri, 22 Apr 2016 06:37:41 +0800

golang-fsnotify (1.2.9-1) unstable; urgency=medium

  * Update to 1.2.9 upstream release
  * Build-Depends on gccgo where golang-go is not available
  * Add myself to the list of Uploaders

 -- Anthony Fok <foka@debian.org>  Thu, 14 Jan 2016 02:28:11 -0700

golang-fsnotify (1.2.1-1) unstable; urgency=medium

  * Update to 1.2.1 upstream release
  * Transition to "golang-github-go-fsnotify-fsnotify-dev" package for pkg-go
    policy compliance

 -- Tianon Gravi <tianon@debian.org>  Wed, 04 Nov 2015 01:36:25 -0800

golang-fsnotify (1.2.0-1) unstable; urgency=medium

  * Update to 1.2.0 upstream release.

 -- Tianon Gravi <admwiggin@gmail.com>  Sat, 02 May 2015 23:33:47 -0600

golang-fsnotify (1.1.0-1) experimental; urgency=medium

  * Initial release.

 -- Tianon Gravi <admwiggin@gmail.com>  Tue, 10 Mar 2015 21:51:47 +0000