1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23
|
export DH_VERBOSE=1
export DH_GOLANG_EXCLUDES := manualtest leveldb/testutil
DEBVERS ?= $(shell dpkg-parsechangelog | sed -n -e 's/^Version: //p')
VERSION ?= $(shell echo '$(DEBVERS)' | sed 's/^[[:digit:]]*://; s/[-].*//')
DEBPKGNAME ?= $(shell dpkg-parsechangelog | sed -n -e 's/^Source: //p')
%:
dh $@ --buildsystem=golang --with=golang
override_dh_auto_test:
dh_auto_test -- -timeout 20m
gen-orig-tgz:
if [ ! -f ../$(DEBPKGNAME)_$(VERSION).orig.tar.gz ] ; then \
git archive --format=tar.gz --prefix=$(DEBPKGNAME)-$(VERSION)/ \
upstream/$(VERSION) >../$(DEBPKGNAME)_$(VERSION).orig.tar.gz; \
fi
|