File: setup.py

package info (click to toggle)
goocalendar 0.7.1-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 280 kB
  • sloc: python: 1,575; makefile: 135
file content (51 lines) | stat: -rw-r--r-- 1,766 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
#!/usr/bin/env python
# -*- coding: utf-8 -*-
# This file is part of GooCalendar.  The COPYRIGHT file at the top level of
# this repository contains the full copyright notices and license terms.

import io
import os
import re
from setuptools import setup, find_packages


def read(fname):
    return io.open(
        os.path.join(os.path.dirname(__file__), fname),
        'r', encoding='utf-8').read()


def get_version():
    init = read(os.path.join('goocalendar', '__init__.py'))
    return re.search("__version__ = '([0-9.]*)'", init).group(1)


setup(name='GooCalendar',
    version=get_version(),
    description='A calendar widget for GTK using PyGoocanvas',
    long_description=read('README'),
    author='Tryton',
    author_email='goocalendar@tryton.org',
    url='https://pypi.python.org/pypi/goocalendar',
    download_url='https://downloads.tryton.org/goocalendar/',
    project_urls={
        "Bug Tracker": 'https://goocalendar.tryton.org/',
        "Documentation": 'https://goocalendar.readthedocs.org/',
        "Forum": 'https://discuss.tryton.org/tags/goocalendar',
        "Source Code": 'https://hg.tryton.org/goocalendar/',
        },
    keywords='calendar GTK GooCanvas widget',
    packages=find_packages(),
    classifiers=[
        'Development Status :: 5 - Production/Stable',
        'Environment :: X11 Applications :: GTK',
        'Intended Audience :: Developers',
        'License :: OSI Approved :: GNU General Public License v2 (GPLv2)',
        'Operating System :: OS Independent',
        'Programming Language :: Python :: 3',
        'Topic :: Software Development :: Libraries :: Python Modules',
        'Topic :: Software Development :: Widget Sets',
        ],
    license='GPL-2',
    python_requires='>=3.4',
    )