1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
|
Description: Remove all white-spaces from attributes before generating the UIDs.
Author: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Abstract:
During development of the GOsa² SchoolManager Add-On, it was discovered that in
some cases the gen_uids() function would return UIDs that contained blanks.
@@ -3804,6 +3804,7 @@
$value = iconv('UTF-8', 'US-ASCII//TRANSLIT', $value);
}
$value = preg_replace('/[^(\x20-\x7F)]*/','',$value);
+ $value = preg_replace('/\s/', '', $value);
$attributes[$name] = strtolower($value);
}
|